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Intuit ProFile 

ProFile will carry forward information from a return created in the 2001-2004 

T2 module (version 2003.0.0 or later) which did not include the RACDetails 

worksheet. 

ProFile carries forward the same information as in the 2001-2004 ProFile T2. 

The only difference is that now this information will appear on RACDetails as 

well as on the form where the information appeared in the 2001-2004 ProFile 

T2. 

You can review RACDetails in the new file. This is now the source form for 

related and associated corporation information that appears throughout the 

return. Review in particular for duplicate slips that ProFile may have created 

during the carryfoward. ProFile merges information onto RACDetails based on 

the business number and name that appear on various forms in the past year 

file. 

If the spelling of a corporation name was not consistent, or if a there was a 

typo in the business number for an associated corporation on any form in the 

source file, ProFile would treat this as a different corporation and create a 

second slip. RACDetails eliminates this possibility of data inconsistency 

between different forms that have information for the same set of related or 

associated corporations. 

You will need to complete all the current year information on RACDetails in 

the new return. 

For each T2 file, ProFile consolidates all the information for related and/ 

or associated corporations on a worksheet called Related and Associated 

Corporations Details (RACDetails). This worksheet eliminates repetitive data entry on 

a number of forms that require details about any related and associated corporations. 

Enter related and associated corporation details once on RACDetails, and ProFile 

automatically transfers information as required throughout the return. 

 

ProFile T2 also offers an Intuitive Copy-Paste that eliminates repetitive data entry in 

subsequent T2 files involving the same related group of corporations. Once you have 

entered all the information for related and associated corporations on the RACDetails 

form for the first corporation, you can copy these details from the first file and paste 

into RACDetails in other T2 files. ProFile even handle the switch in which the original 

filing corporation now appears in the list of related and associated corporations. 

 

Preparing T2 returns for 
Related and Associated 
Corporations 
 

Carry forward prior year data 

http://profile.intuit.ca/professional-tax-software/index.jsp


 

 
 

 

Forms using RACDetails data 

On all forms that draw information from RACDetails, fields are 

nonedit (green). You will need to enter and modify information 

about related and associated corporations on the RACDetails 

worksheet. 
To move between a schedule and RACDetails, double-click on a 

corporation name on any schedule to jump directly to the 

corresponding “slip” for that corporation on RACDetails. 

Schedule 23 (S23) and other forms that include information from 

RACDetails also show quick link at the top of each such form to jump 

direct to RACDetails where you can update information. 

For the filing corporation, complete the Info form. RACDetails 

handles only the information for companies related to or associated 

with the filing corporation.1. Open a new current tax year ProFile T1 

file. 

Questions and answers 
 

1. Why can’t I click a drop-down selection on RA 
Schedules? 
Although the drop-down menus still appear on the RA 
Schedules, you must enter the information in the 
corresponding field on RACDetails as this is the source 
form that transfers to other Schedules in the return. 
 

2. Where do I enter the filing corporation information? 
Enter this information on the Info form and directly on the 
RA Schedules. Certain information transfers from the 
Info form to the RA Schedules (green, non-edit text), 
while other fields are data entry fields and can be 
entered directly on the RA Schedules (black text). 
 

3. How do I remove information for a single corporation on 
RACDetails?  
Clearing the form (Form > Clear form) will delete all 
information for all corporations on RACDetails. To delete 
the information for a single corporation, right-click on the 
particular “slip” you want to delete, and choose Delete 
column. 
 

4. Can I print RACDetails? 
No. Since the print job for the entire form is potentially 
very large, we have restricted this form so that it does 
not print. 

5. I don’t want ProFile to complete a particular RA 
Schedule from RACDetails. 
RACDetails is designed to transfer information based on 
CRA rules. If information is transferring from RACDetails 
to a particular RA Schedule, the CRA requires that 
schedule be included in the return. To manually exclude 
that schedule from a print job, clear that form from the 
print job on the Print Selection dialog (File > Print).  
 

6. Are there any navigation shortcuts to move between 
forms in the return, and RACDetails? 
ProFile has hyperlinks on RACDetails and on destination 
Schedules so that you can quickly jump between the 
two, and keep your focus on the same corporation. 
 

7. 7 Do I need to change my audit and review process now 
that I enter related and associated corporation 
information on RACDetails?  
You can follow the same review process you have in the 
past. ProFile audit messages are associated with the 
same fields (on the destination forms) as they were 
previously. The same audit messages appear on the 

related fields of RACDetails. 

Slips sidebar on RACDetails 

 

The RACDetails worksheet is in the ProFile slip format so that you can 

enter any number of related or associated corporations, with 

complete details, on a single worksheet. 

 

ProFile has a sidebar view to help you find particular slips in a client 

file. You can resize the sidebar to adjust the display for your monitor. 

Slip numbers correspond to the order of data entry, however, the 

sidebar displays the list alphabetically. You can click any corporation 

that appears on the slip sidebar to jump directly to that slip. 

 

To delete all the information for the current related or associated 

corporation select Edit>Delete Column. Select Edit>Insert Column to 

create a new RACDetails slip, or click <New> on the Slips sidebar. 

 

You can also scroll through the slips if you are reviewing a smaller 

file. Just drag the horizontal scroll bar that appears across the top of 

the slips. 

 

 
 

1.  Click on a sidebar column heading to sort the list of 

corporations alphabetically by name . Click on a name to 

jump directly to the associated slip. 

2. To resize the sidebar, click and drag on the frame that divides 

the sidebar from the forms in the Edit window. 

3. At the end of the list, you’ll find the <New> option. Click New 

to begin entering data on a blank slip. You can also press 

<Ctrl+Enter> to move to the top of the next slip. If you are 

working on the last slip created, <Ctrl+Enter> will take you to 

a new blank slip. 

4. You can scroll through the slips using the horizontal scroll bar 

across the top of the slip. 

5. While you are entering information, you can move back and 

forth between the slips without losing your place. ProFile 

moves you to the same field on the selected slip.  

 

Automatic print selection  
 

From RACDetails, information about related and associated 

corporations transfers throughout the return. This transfer is based 

on the government rules concerning which forms are required to be 

filed.  

Form selection for printing is based on the tax situation of the filing 

corporation and not on the included on RACDetails. If RACDetails 

includes information that is not needed for the particular filing 

corporation’s return ProFile will print no unnecessary forms  

Using the default settings for printing, ProFile will select all the 

required forms. If you choose not to print any of the selected forms, 

you will need to change the print selection under Options > Form 

selection 

Related: How to setup Form Selection 

http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=HOW25747


 
 

Related and Associated Corporations Worksheet 
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ProFile uses a “slip” on RACDetails for each related and/or associated 

corporation. RACDetails is designed to help you manage the 

information for related and associated corporations. It is not 

available to include in any print jobs, The slips share information that 

is common to all of the related or associated corporations. For these 

fields (such as “Allocate business limit using % or $”) you can change 

the selection on any slip and ProFile updates all the slips on 

RACDetails. 

 

Relationship code 

 

The RACDetails worksheet includes a field to indicate the relationship 

code for each related or associated corporation. Because there are 

calculations that depend on this code, you must enter a Relationship 

Code for each related or associated corporation before ProFile will 

transfer any information from the RACDetails worksheet to other 

forms in the T2 file. 

 

Codes 1,2 and 3 at this field means that the corporation indicated on 

the RACDetails slip will be treated as an associated corporation. Code 

4 entered at this field will be treated as a related corporation. 

 

 
 

If the information you have entered on RACDetails is not transferring 

to other forms that require information about related or associated 

corporations, check first that you have entered the Relationship Code 

for each.  

 

 

Intuitive Copy – Paste  

 

Use this feature if you are preparing another T2 return for a 

corporation that belongs to the same associated group of 

corporations as another for which you have already completed a 

return. Intuitive Copy-Paste transfers all the relevant information 

from the first RACDetails worksheet in one file to the second 

RACDetails worksheet in another file. Depending on how many 

related or associated corporations are in the group, this may amount 

to a tremendous time savings! 

 

Pasting RACDetails into another file will overwrite all the data in the 

destination file. ProFile will not retain any different slips in the 

destination file. This feature is designed for use when another filing 

corporation shares the same set of related corporations. 

 

The Intuitive Copy-Paste is a one-time transfer of information. The 

files are not linked, and there is no ongoing data transfer between 

the two files. If you updated information for a related or associated 

corporation in one file, you will need to update that information in 

the files for other corporations in the group. 

 

 
 
To use Intuitive Copy - Paste with RACDetails, open the worksheet in the 
first file you prepared for one of the associated corporations. Choose Edit 
> Intuitive Copy from the menu. Open the RACDetails form in another file, 
for one of the related corporations. Choose Edit > Intuitive Paste. 
 

ProFile manages the RACDetails difference between 

files 
 

Of course the RACDetails worksheet in the file for the second 
corporation handled requires a switch. Associated Company 2 will 
appear on RACDetails in the return for Associated Company 1.  
 
When you Intuitive Copy-Paste from RACDetails for Associated 
Company 1 into a new file for Company 2, ProFile checks the Info 
form in the original file and the new file. Make sure you have already 
completed these fields on the Info form of the second file before you 
Copy-Paste from the first file so that ProFile can identify which 
corporation in the associated group the data is being pasted in. 
 
Based on the Corporation name and Business Number, ProFile 
handles the switch automatically. Associated Company 1 gets a new 
slip on RACDetails, and Associated Company 2 (now the filing 
corporation in the second return), disappears from RACDetails. 


