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Chapter 6 – Exploring ProFile  
 

Topics 
 

 Introduction 

 Getting Started 

 QuickStart dialog 

 Forms window 

 Fields, colours and indicators 

 Right-click menu 

 Form Explorer 

 Keyboard shortcuts 

 Create or open a file 

 Coupling T1 returns 

 Forms 

 Enter data 

 Share data 

 Audit and review 

 Save and close a file 

 Print 

 EFILE 

 What we learned  

 Classroom Review (Quiz) 
 

Introduction to Chapter 6 

Estimated time 
 
About 60 min 
 
In this chapter, we will: 
 

 Navigate in ProFile 

 Work in Profile 
 
Let’s get started! 
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Getting Started 
 
ProFile T1 software is reliable, easy-to-use and offers sophisticated features that will make the 
tax season more productive for even the experienced T1 tax professional. ProFile T1 can carry-
forward the data from past year returns created using certain competitors’ software. Whether 
you carry forward individual client files, or carry files forward in batches, you will find the process 
quick and convenient.  
 
Using ProFile`s WYSIWYG (what you see is what you get) forms, you can view and edit federal T1 
and Québec TP1 forms in French or English. When it comes time to print a return, you can print 
most of the forms in either language or both, at the click of a button.  
 

New user 
 

If you are a first time ProFile T1 user, follow this checklist to set up the program and get ready 
for using the software. 
 

1. Configure tax preparer information.  

Enter your preparer information under Options > Environment > Preparer. If you are a 

discounter, complete the information in Options > Environment > Discounter. 

2. Review ProFile options and database settings.  

Under Options > Module > T1, you’ll find items that relate specifically to working with T1 

returns (such as file management settings, a disclaimer that appears on some forms and 

a form header that will print on all forms). Under Options > Database, you’ll find settings 

related to the database, including set-up. 

3. Carry forward data from last year’s tax software.  

Look under Options > Module > T1 for specific carryforward features. 

4. Decide to print joint (husband and wife) or individual client letters and invoices.  

If you do not want to print letters and invoices addressed to both husband and wife 

together, go to Options > Module > T1 > General > Options and clear those options. 

Otherwise, ProFile will print joint client documentation. You can also decide if you wish 

to have formal (for example, Dear Mr. Smith:) or casual (for example, Dear John:) 

salutations. 

5. Review other options.  

Take some time to review the other options found under the Options menu. The software 

ships with the most popular options selected, so unless you have different preferences, 

the defaults should be acceptable. 

6. Set up tax return defaults.  
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When you create new tax returns, you may wish to have certain fields default to your 

usual values -- for example, the province of residence. Just follow the instructions for 

creating a file based on default settings. 

7. Set up EFILE using the EFILE > Options Wizard. 

If you EFILE your returns, you’ll need to configure your EFILE > Options. You can easily do 

this by running the EFILE > Options > Wizard that guides you through the setup process. 

8. Run the tutorials.  

I know you are anxious to get started, but I recommend you take the time to go through 

the tutorials (in the main menu). These will demonstrate many of the basic concepts of 

ProFile. 

 

 Note: If you are setting up ProFile T1 to use on a network, refer to the 
‘Network’ section of the ProFile in-product help. Here you will find instructions 
for setting up your files in shared server directories. 

 

Navigate 

 
Use these tools to help you navigate and perform functions within ProFile. 
 
This section will cover the following sections of: 
 

 QuickStart dialog 

 Forms window 

 Fields, colours and indicators 

 Right-click menu 

 Form Explorer 

 Keyboard shortcuts 
 

QuickStart dialog  
 
When you start the software, you will see the QuickStart dialog box:  
 

1. To see the QuickStart options for different ProFile modules, click the tabs across the top 

of the QuickStart dialog box. A tab will appear for each installed module that’s included 

in your license (under Help > License). Click a down arrow beside a tab for access to 

multiple years of some ProFile modules.  
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2. If you’ve never run ProFile before, I recommend that you try the tutorials and use the 

other tools available from Resource Corner to familiarize yourself with the basic operation 

of the software.  

3. From this dialog box, you can also choose to create a new file.  

4. Click [Open] an existing file to work on a file you saved previously. This functions the same 

way as the File menu option File > Open.  

5. Click [Carryforward] a file to carry forward a tax return from a previous year.  

6. ProFile maintains a list of files you’ve worked on recently. To re-open a recent file, double-

click on the file name in this list. This functions the same way as the menu option File > 

Reopen.  

7. Clear this checkbox if you do not want to see the QuickStart dialog each time you start 

ProFile. You can re-activate the QuickStart dialog box from the Help menu.  

 

Forms window  

Menus  
 
Use the main menu to access all the commands available in the software. If you would like to 
choose from a list of commands which relate to a specific area on the screen (such as data fields 
or areas in a dialog box), right-click on the area for a context-sensitive menu. The Form Explorer 
also gives you a number of functions relating to finding, opening and sorting forms.  
 
Many of the main commands also have corresponding shortcut keystrokes. For example, you can 
press <F9> (function key 9) to display the active auditor. The shortcut keystrokes are listed beside 
the drop-down menu commands.  
 
You can access the main menu using the keyboard using <F10> or by pressing <Alt> and the 
underlined letter of your desired main menu command. For example, press <Alt+F> to access the 
File menu.  
 
Several menu commands display dialog boxes that you interact with to accomplish a task. These 
dialog boxes have a small question mark in the upper right hand corner beside the close box. 
Click on this small question mark. The cursor will change to an arrow carrying a question mark – 
then, click on an area of the dialog box to see help related specifically to that item.  
 
Some of the main commands are also available on the toolbar. Move your cursor over a toolbar 
button – after a short pause, a brief message will appear describing the function of the button.  
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Toolbars  
 
ProFile has four different toolbars that you can display or hide, depending on which you like to 
use. You can also drag-and-drop the toolbars to different positions on your desktop. Stack them, 
float them or string them in a row to create the desktop that works for you. Just select Toolbars 
under the Options menu and then click on the toolbar you want to hide or display.  
 

 
 
As with other ProFile options (like dialog sizes and positions), the software remembers your 
toolbar configuration when you exit and restart the program.  
 

 Hint: Customize the ProFile toolbars to suit your preferences. Turn the 
toolbars on or off under Options > Toolbars. For more information on toolbar 
options, refer to Configuration help. 

  

Shortcuts toolbar  
 
The Shortcuts toolbar gives you access to the most commonly used ProFile features at the click 
of a button.  
 

 
 

The arrow keys on the Shortcuts toolbar  are context-sensitive. With your cursor in a 
field, click the right (Jump) arrow to jump to the first form that is a source for that field. The left 
arrow is the toolbar option to Backtrack, and returns you to the form active immediately before 
the current form.  
 
Associated with these arrows are drop-down lists. Like the context-sensitive menu, the Jump 
arrow list shows all forms that are sources for the field where your cursor is located. 
 
The list for the Backtrack arrow shows forms you accessed earlier in this session. Using the 
Backtrack arrow repeatedly, you can retrace your steps. This will work whether you opened forms 
using the right-click menu, the Jump arrow or the Form Explorer. The Backtrack list includes the 
last 20 forms you have visited. If you revisited forms, they will appear more than once in the list. 
If you select a form that is part-way down the list (using the Backtrack key or the mouse), the list 
will truncate at that point, and you will no longer see the forms you accessed after the selected 
form.  
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Audit and review toolbar  
 
Audit and review marks give you a palette of tools that you can use in your review process. Just 
click the toolbar icon to select a mark, then click a field to indicate its review status (signed off 
correct, incorrect or unresolved).  
 

 
 

Jump Bar 
 
Click a form icon on the Jump bar to jump to that form. You can also customize your Jump bar to 
include different forms that you like to have at your fingertips. Just open a form in the Forms 
toolbar, click and hold your cursor on the form tab icon until the cursor changes to show a small 
white square, and then drag-and-drop onto the Jump bar.  
 

 
 
To remove a form from the Jump bar, just drag-and-drop off the Jump bar, releasing the cursor 
anywhere else on your desktop.  
 

 You can drag a form icon from the Form Explorer onto the Jump Bar. If you 
drag the icon for a form that does not display in the Forms window, for example, 
the Memo Summary, ProFile will print the form. The icon will not appear on the 
Jump Bar.  

 
There is also a right-click menu for the Jump Bar so that you can Jump, Print a form or display/hide 
the form captions. 
  

Move the toolbars  
 
After you select the toolbars you want to use (Options > Toolbars), drag and drop them to the 
positions you prefer. To move a toolbar, just click and hold on the toolbar handle and then drag 
the toolbar to the new location.  
 
You can move toolbars between the top and bottom of the Forms window, rearrange their 
sequence in a single line, stack them one above another, or drag them elsewhere on your desktop 
where they will ‘float’.  
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Tabs  
 
For each form that is open in the Forms toolbar, a corresponding tab appears at the top of the 
Forms window.  
 

 
 
Click on a tab to make that form active in the Forms window. If you wish to open a form which 
does not appear on the tabs, select the ‘Form Explorer’ and open a new form. When you open a 
new form, ProFile places the new tab to the right of the current form. If you open several forms 
at the same time, you will see a number of tabs at the top of the Forms toolbar.  
 
When you close a form ProFile removes the form from the Forms toolbar. 
 

Automatically rearrange tabs  
 
Select Options > Environment > Edit > Restack Tabs on Open and ProFile will automatically 
rearrange the tabs when you open a new form so that the tab for the form you just opened 
appears to the right of the current form and in front of all the other forms. This allows you to 
close the new form and automatically display the previous form.  
 
If this option is disabled and you jump to a form that is already open, the software simply makes 
the form active.  
 
This option is enabled by default. If you find the rearrangement of tabs by the software confusing, 
you should disable it.  
 

Maximum number of tabs  
 
Select Options > Environment > Edit > Maximum Open Tabs and enter a number to limit the 
number of tabs (and therefore forms) open at one time. When you reach the limit will 
automatically close a form when you open a new one.  
 

Appearance  
 
Select Options > Environment > Display > Tab icons to display the form name and a form icon on 
each form tab at the top of the Forms window. Clear this option to display only the form name.  
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Switch between open file 
  
You can load as many files as you want. Each file appears in a different window on your desktop. 
If you maximize the window, you will see only one file at any time. Otherwise, you may arrange 
and size windows to view several files at the same time. 
 

 Note: Multi-Monitor feature is much easier now for this method. 

 

The Window menu  
 
The Window menu contains commands to organize one or more forms open on your desktop. 
You can also open forms in the same return within a different window. This lets you monitor how 
your changes in one form affect other forms in the same return. 
 
When you have multiple client files open at the same time, you can switch between these files 
using the Form Explorer or the Window menu where the names of open files appear in a list. 
 

Open a form in a new Forms window  
 

 Tip: Keep in mind that you can also load several files at the same time. 
Each of these files also has a separate Forms window, but does not share data 
with other files. The Window menu can help manage these files. 

 
Typically, you will only have one Forms window while viewing a client file. Forms Windows 
contain tabs at the top for each form that is currently open. If you open a form in a new window, 
you display a new Forms window for the active client’s file. 
 
Within this new Forms window, you can open a completely different set of forms. They’re still 
the same client file or return, so calculations and data entered in one Forms window might 
change amounts in other Forms Windows. 
 
This feature is useful if you wish to view part of a form while editing another form.  
 
To open a new window:  
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1. Select Form > Open in new window from the menu system; or right-click on the form and 

select ‘New window’.  

2. Select Window > Tile to show both Forms windows on the screen.  

 

Launching a file in a new ProFile window in a second monitor (Multi-Monitor) 
 
If your system has two screens (computer monitors) and you have multiple files open, you can 
tell ProFile to open one of those files on the other screen.  

 
 
To do so: 

1. Switch to the file that you want to open in the other screen (select it from the Window 

menu). 

2. Select Window > Launch current window. 

ProFile opens the current file in a separate ProFile window on the other screen. 

 
To switch between different launched ProFile Windows: 

 Point to Window > Launched Windows, and choose the file that you want to view. 

 

Tiling Windows horizontally 
 
The Tile Horizontally feature rearranges the Windows on the screen so each one occupies the 
same space. For example, if there are four Windows, each displays in a corner of the screen. The 
tile feature is useful if you want to monitor changes happening on two forms in the same client 
file or in different client files. 
 

Tile Windows to two forms in the same client file 
For example, in ProFile T1 you might want to look at the T1 return while making changes to the 
RRSP form. To try using multiple Windows within a single file, first make sure that you have only 
one client data file open. You can check which files are open under the Window menu.  
 

1. Open the RRSP form. Right-click on the form and select ‘New Window’.  

2. Select Window > Tile Horizontally (or click on the corresponding toolbar item). ProFile 

arranges the two Windows to use all the available space.  

3. In the lower Forms window, open the T1 form.  
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4. As you make changes to the RRSP form, you will automatically see the effect on the T1 

form in the window above.  

 

Tile Windows to view multiple files  
As described earlier, you can also open multiple Windows for different client files or returns. 
These files don’t have to be the same type: you can open both a T1 tax return and a T2 tax return 
at the same time.  
 
After you tile Windows, you can drag and drop data between different files, even if the files are 
of different types, such as between an FX file and a T1 return. However, the type of information 
in the field must be the same (for example, you cannot drag a text value into a numeric field). 
 

Cascade Windows  
 
Window > Cascade rearranges all Windows so that you can see the title bar of each window. You 
can see the full contents of the window that is ‘on top’ of the others. Use cascade to keep track 
of the files open on your desktop and to move quickly between these files. Double-click the title 
bar of an Forms window to maximize it within the ProFile window. 
 

Arrange Windows  
 

Window > Arrange arranges all active Windows either in a tiled or cascade fashion. The Windows 
are all minimized in order to accommodate all of the files. 
  

Fields, colours and indicators  
 
Each field shows some type of data: currency, percentage, date, yes or no, radio buttons (that 
allow you to select a single option from a list of mutually exclusive options, for example, Male or 
Female), checkboxes (which allow you to set listed options ‘on’ or ‘off’), or drop-down lists (which 
allow you to select a single item from a list of items, for example, the province name from all of 
the province and territory names).  
 
ProFile has several types of data fields that allow you to enter different kinds of information. 
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Text fields  
 

Text fields allow you to enter any combination of numbers, letters and other characters. Similar 
text fields (such as medical expenses, T5 slip names, Mutual fund names, etc.) have predictive 
typing. ProFile ‘guesses’ your entries based on a list of your previous entries in the field.  
 
You can select capitalization options under Options > Environment > Edit > Capitalization:  
 

 Normal capitalization (default) alphanumeric fields appear as you type them. Letters 

appear in uppercase only when you use the <Shift> key.  

 All Uppercase automatically capitalizes all alphanumeric fields. (This does not affect data 

entry of numbers, only letters.)  

 Smart Capitalization automatically capitalizes the first letter of every word (this is 

particularly useful for name and address fields.)  

 
You cannot format text in fields as in a word processor. For example, you cannot change the font 
or colour of the text or make the text appear as bold or italic.  
 

Numeric fields  
 
Numeric fields contain dollar amounts, percentages and other numbers. These are the types of 
numeric fields:  
 

 Edit fields have black text (or purple for information carried forward). Both mean that you 

can enter data directly in the field.  

 Overrideable fields blue text and are calculated automatically by ProFile. If Options > 

Environment > Edit > Automatic override is selected (the default setting), you can 

override a calculated field simply by typing a new number (otherwise press <F2> to 

override). A red diamond will appear in the field’s status box, the black box to the right of 

each field. The field’s contents will also be red to indicate the override. To restore the 

automatic calculation, press <F2> when your cursor is in the field. Select Options > 

Environment > Edit > Audible override to hear a ‘click’ when you override a field. The 

Active Auditor lists all fields that have overrides, and displays the automatic calculation 

for comparison.  

 

 To override a format (for example, to enter a zip code into a postal code 
field) press <Ctrl+F2> while your cursor is in the field, and then begin typing.  
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 Non edit fields have green text and are also calculated by ProFile. You cannot override 

these fields since overriding would result in invalid calculations. 

  

Options for numeric fields  
 
You can configure several data entry and display options for numeric fields  
 

 Select Options > Environment > Edit > Fixed decimal entry to enter amounts data without 

having to type the decimal point. For example, if you type the characters ‘12345’ and 

press <Enter>, the number 123.45 appears in the field. When you clear this option and 

type the characters ‘12345’ and press <Enter>, the number 12,345.00 appears in the field. 

You must explicitly type the point character in order to enter cents.  

 Select Options > Environment > Display > Bracket negative numbers to display and print 

all negative values inside brackets (an accounting standard). Clear this option to display 

negative values with a minus sign.  

 Select Options > Environment > Display > Zeros in NIL fields to display a zero in empty 

fields in the tax modules. Clear this option to leave empty fields blank. This option does 

not modify printed materials; printed forms will always show zeros in the blank fields (as 

required by CRA).  

 Select Options > Environment > Display > Line Decimal Separators to display a vertical 

line to separate the dollar amounts from the cent amounts on forms. Clear this option to 

display a decimal point.  

 Select Options > Environment > Display > Highlight Negatives highlight negative amounts 

in bold.  

 

Date fields  
 
Date fields allow you to enter dates (e.g. yyyy/dd/mm or dd/mm/yyyy). You do not need to enter 
the ‘/’ characters; ProFile formats dates automatically.  
On a date field, press <=> to automatically enter the current date, (according to your system 
date). Press <+> to advance the date by one day. Press <-> to roll the date back by one day. Press 
the <Spacebar> or </> when your cursor is on the year to insert the file year. On a T2 that will be 
the year in which the fiscal period ends. Press <\> when your cursor is on the year to insert the 
year prior to the file year.  
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Drop-down lists  
 

Drop-down lists allow you to select a single item from a list of items. Click on the [down arrow] 
in the field’s status box or press <Ctrl+Down Arrow> to see the list. You can also type the first 
few characters of your selection. ProFile will automatically complete the entry in the field. Text 
fields with predictive typing work in a similar manner—press <Ctrl+Down Arrow> to see the 
predictive typing list.  
 

Colours  
 
The colour of a field can tell you a lot. Here’s a key to the range of colours for field text and 
background:  
 

 Black text means it is a number that you supply (data input);  

 Blue text means it is a calculated number or default and you can override (with <F2> if 

your options do not specify automatic overrides);  

 Red text means it is a calculated number but is currently overridden (related to the red 

diamond that appears) -- press <F2> to restore the automatic calculation;  

 Green text indicates that it is a calculated number but you cannot override it;  

 Purple text shows data carried forward from a previous year’s tax return or data that you 

have imported.  

 
There are also five different field background colours:  
 

 White means there is no additional information associated with the field.  

 Yellow indicates that the field contents have caused a Passive audit message;  

 Green means a calculator tape or memo is attached; and  

 Orange means a Variance message is attached.  

 Red indicates that you have entered invalid data in the field, and ProFile cannot store the 

information (for example, an invalid date). You cannot move your cursor to another field 

until you correct the entry in a red field.  

 
Putting your cursor over a field with any background colour other than white will display a 
context-sensitive message.  
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Status box  
 
The Status Box is the black box to the right of most fields. Status box indicators give you additional 
information:  
 

 A down arrow in the status box means there is a drop-down list associated with the field. 

Press <Space> or <Ctrl+Down Arrow> on the keyboard to select from the list. Or, click the 

[down arrow] with your mouse to select an item from the list.  

 An up arrow in the status box tells you the field’s data comes from (and is calculated on) 

another form. You can easily open this other source form using a technique known as 

jumping or drilling down. To open the source form, click on the field using your right 

mouse button. A context-sensitive menu will appear. One (or maybe several) of the 

options will be the name(s) of the source form(s). Click on a form name to jump to it. 

 

 Certain fields have an up arrow and also allow you to enter data (for 
example, on the Schedule 4 in ProFile T1). Either data flows into these fields 
from other forms or you can enter amounts directly in the field.  

 

 A red diamond appears in the status box if you have overridden the software’s automatic 

calculation. To restore the automatic calculation, press <F2> when your cursor is in the 

field. Press <Ctrl+F2> to override a format (for example, to enter a zip code into a postal 

code field).  

 A green diamond will appear on a Quebec TP1 form if the related field on the federal 

form has been overridden.  

 

Right-click menu  
 

The right-click, context-sensitive menu will give you different options depending on what form 
you are using in the Forms window. Even on the same form, the context-sensitive menu will 
change, depending on the location of your cursor.  
 
On a table, there will be features for editing the table. On a field that takes data from other forms, 
there will be jump links. Get in the habit of using the context-sensitive menu to get the most from 
your ProFile software. 
 
On some tables you can right-click for options specific to the table. For example, on the Donations 
table, right-click to sort the table alphabetically. For coupled T1 returns, either spouse can claim 
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the charitable donations. Look for the transfer option in the right-click menu. You can check the 
impact on tax payable depending on which spouse makes the claim by moving the amounts back 
and forth between the returns with a single click. 
 

Form Explorer  
 
The most important feature in the ProFile software is the Form Explorer. Like the Windows 
Explorer, the Form Explorer lists the contents of each ProFile module. You can use the Form 
Explorer to select, open and print any of the many forms in the software.  
 
The Form Explorer helps you manage, arrange, print, and open the many forms in the software. 
If you are new to the software, try the ‘Form Explorer’ tutorial, which covers all of the Form 
Explorer topics extensively in an interactive fashion.  
 
The Form Explorer is very much like the Windows Explorer. However, instead of helping you 
search for files (as you do in the Windows Explorer), the Form Explorer helps you search for 
forms. You can search forms by form name, by line number or by keyword search.  
 
To display the Form Explorer, click the [Form Explorer] button on the toolbar beneath the menu 
or press <F4>.  
 

 Hint: To get help on any item of the Form Explorer, click the small question 
mark in the upper right corner (beside the close box) then, click on any element 
of the Form Explorer.  

 
The Form Explorer will automatically disappear from view when you switch to the Forms window 
or when you select a form to edit. You can also close the Form Explorer manually by clicking on 
its [Close] button (the button with an ‘X’ at the top right corner of the Form Explorer).  
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Use the Form Explorer  
 

 
 

1. The Form Explorer Category bar organizes the many ProFile forms by category. Click a 

category name or file folder on the Category bar to display all the forms in that category.  

The Category bar on the left has separate sliding bars in the harmonized modules (i.e. 

ProFile T1/TP1, T3/TP-646). To switch between ProFile T1 forms and ProFile TP1 forms, 

click one of the sliding bars. To view all the federal and provincial forms together, click 

the Forms bar. Under each category, the forms are sorted into folders by type.  

 

 If you purchase a ProFile module that includes Quebec forms, you will see 
federal and provincial form groups on the Form Explorer Category bar. Select 
either group, or click [Forms] to display both federal and provincial forms 
together.  

 
2. Each form has a unique name. Enter the form name into the ‘Form:’ field at the top of the 

Form Explorer and press <Enter> to open the form. Or, double-click a form name to open 

it. You can also highlight the form name and click [Open].  

3. If you have more than one return open, select the client name from the drop-down list to 

switch between them.  

4. Click one of the five view buttons to select a different Form Explorer view.  

5. There are also categories called: All, Used, Data entered, and Last year.  

The All category displays all the forms available in the file that’s open in the Forms 

window. The list of forms will vary depending on the taxpayer’s province of residence.  
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The Used category displays all the forms that include calculations for the current file. This 

includes a form that is performing an automatic calculation for the taxpayer, although 

you may not have entered any data directly on that form.  

The Data entered category displays all the forms where you have entered amounts for 

this taxpayer’s return.  

Finally, when you are working with a file that you have carried forward, the category 

called Last year will display the ProFile forms that contained data in last year’s file.  

6. Right-click a form name (or the Form Explorer) for a context-sensitive menu. The context-

sensitive menu in the Form Explorer includes view options.  

7. Select Options > Environment > Edit > Form Explorer Checklist to use the Form Explorer 

as a checklist where you identify all the forms you plan to use, before you begin to enter 

data in the file.  

 

Form Explorer views  
 
In the Form Explorer there are four different views, each with its own characteristics. The Goto 
menu lets you open a particular view in the Form Explorer. You can also access these views using 
the buttons of the Form Explorer dialog box.  
 
Use the scroll bar (when it appears) to see more forms. Click and drag on the bottom right corner 
to resize the Form Explorer.  
 
The views are:  
 

 The List view accommodates more form names and also allows you to arrange the 

different forms into groups. A small red box with a white check mark in the upper right 

corner of the form icon indicates that you have entered data on that form. Click the [Right 

Mouse] button anywhere in the list view dialog box and select ‘Arrange’ from the context-

sensitive menu that appears.  

 The Detail view allows you to sort the list of forms. Simply click on the heading bar of the 

Form Explorer window (for example, on ‘Form name’ or ‘Category’). Click a second time 

to reverse the order of the forms in that category. You can also right-click and select 

‘Arrange’.  

 To resize a category column, move the cursor to the line between the headings on 

the bar, click and drag the line left or right. If you wish to see a list of those forms 

that contain data, click on the [Used] column and all the forms with data will 

appear first in the list.  
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 Click a column heading to sort the list alphabetically, according to that column. To 

sort in reverse order, click on the same column heading again.  

 Click and drag the column heading separator to resize the column. Double-click on 

the column heading separator to automatically adjust the column to the width of 

the widest element in the list.  

 Here’s a quick way to see the forms that have been used: a) click on the [All] tab 

button) click on the ‘Used’ column heading to sort the forms according to their 

Used status. A form is ‘Used’ when you have entered data on the form, or if ProFile 

has determined the form includes relevant calculations.  

 The step determines the processing order. When you are working on forms in the 

Forms window, press <PgDn> at the bottom of a form to go to the next used form. 

Move to the preceding form by pressing <PgUp> at the top of a form (you can also 

use the corresponding toolbar buttons).  

 Use the Keyword view to find forms that relate to a particular topic. For example, to find 

all forms relating to RRSPs, type ‘RRSP’ into the search field. The forms that adhere to this 

topic appear in the bottom portion of the search screen. You can now double-click on any 

of the displayed forms to open it for editing.  

 Use the Line number view to see a list of all the line numbers on the forms. You do not 

have to be in the line number view to jump directly to a line number – just type the line 

number into the Form field and press <Enter> or click [Open].  

 

Arrange icons in the Form Explorer  
To help you find forms quickly, the Form Explorer can arrange the form names in the following 
ways. Simply right-click in the Form Explorer to bring up the context-sensitive menu containing 
the ‘Arrange Icons’ options.  
 

Arrange by name  
The forms in your client’s file are arranged in an alphabetical order. Selecting ‘Arrange by name’ 
again will reverse the alphabetical sort.  
 

Arrange by category  
This is useful in the ‘ALL’ folder. The forms in your client’s file are arranged in a category order.  
 

Arrange by description  
The forms in your client’s file are arranged alphabetically according to their description. 
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Arrange by used  
A form is ‘Used’ if you have entered data into it. In the ‘Detail View’, you can click on the Used 
heading. The software then arranges the forms in your client’s file according to whether or not 
the form has data on it (or if the form has relevant calculations).  
 

Open multiple forms from the Form Explorer  
 
To open several forms in any order:  
 

1. Select a single form by highlighting the form name.  

2. Press and hold the <Ctrl> key.  

3. Click on another form name. Notice that both form names become highlighted.  

 

You can select as many forms as you wish in this manner.  

 

To open several forms that appear in sequential order in the Form Explorer – follow the same 

procedure as above, except use the <Shift> key. When you select the second form name, all the 

forms between the two highlighted form names will also become highlighted.  

 

Once you select any number of forms, you can click on the [Open] button to open all the forms 

into the Forms window.  

 

Display or print a page or section  
 
To jump directly from the Form Explorer to a form section, type the form name, a forward slash 
and then the section number. For example, ‘T1/4’ will jump directly to the ‘Net Income’ section 
of the T1 jacket. Shorter forms may not have different sections.  
 
To jump directly to a particular page of a form, type the form name followed by a hyphen and 
the page number. To go to the T1 jacket, page 3, enter the name ‘T1-3’. This is also useful when 
you want to print a single page, (for example, to print the second page of the T1 jacket, type ‘T1-
2’ and click [Print]). 
 

 To find a section quickly, you can right-click on a form (not on a field) and 
select the section from the context-sensitive menu. With the keyboard, use 
<Shift+Context-sensitive menu key>.  
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Create new forms from the Form Explorer  
 
For certain forms, you can create any number of copies, as required. These forms all contain # in 
the Form Explorer form name. For example, the T2125# form is a business statement in a ProFile 
T1 file. However, your client may have more than one self-employed business.  
 
To create multiple copies of the form:  
 

1. Highlight the T2125#1 icon in the Form Explorer and click the [New] button;  

2. Select ‘New Form’ from the Form menu while T2125#1 is the active form in the Forms 

window;  

3. Right-click on one copy of the form in the Forms window and choose ‘New Form’ from 

the context-sensitive menu. A second form, T2125#2, will appear.  

 

 Note: Transfer of information between T5013 and T2125: ProFile 
automatically transfers corresponding amounts between the T5013 - Statement 
of Partnership Income and T2125 - Statement of Business or Professional 
Activities forms. 

 

Create multiple copies of a single form  
 
Some forms allow you to create any number of copies. For example, the self-employed business 
form (T2125) form is named T2125#1 in the Form Explorer. However, your client may have more 
than one self-employed business. Therefore, you can create multiple copies of a single form.  
 
Follow these steps:   
 

1. Highlight the T2125#1 icon in the Form Explorer and click on the [New] button, OR  

2. Right-click in the form you wish to duplicate and choose ‘New Form’ from the context-

sensitive menu.  

 
A second form, T2125#2, will appear. Once you complete both forms, switch to the Detail view 
in the Form Explorer. Notice that the description for each form includes data that you enter on 
the form.  
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Form Explorer Checklist  
 
You can use the Form Explorer as a checklist to guide your processing. Use this feature if you like 
to select all the forms you need before you begin entering data. To enable the Form Explorer 
check boxes, select Options > Environment > Edit > Form Explorer checklist. Also, select Options 
> Environment > Edit > Continuous forms. The procedure on this page describes the easiest way 
to use the checklist.  
 

 If you want to create a default checklist setting, create a new file and set 
up the defaults. Then, create a file template. Files based on this template use 
the default checklist settings.  

 
1. In the Form Explorer, select the ‘Detail view’. Then, click the [All] tab to display all the 

forms.  

2. Click the column heading Step. This sorts the forms according to their processing step.  

3. You may need to click and drag the bottom right corner of the Form Explorer to resize it 

(if you cannot see the Step column).  

4. You can also click and drag on the column header separators to resize each individual 

column.  

5. Now, move down the Name column and select the forms you wish to include in your 

processing. Select a form by clicking in the checkbox with your mouse or use the <Up 

Arrow> and <Down Arrow> keys to move the highlight bar. Then, press <Space> to 

include/exclude a form.  

6. Once you are finished selecting forms, move the highlight bar to the top of the list. 

Double-click on the form or click [Open] to display the form in the Forms window. Only 

the highlighted form will open.  

 
Once the form is open in the Forms window, use <PgUp> and <PgDn> to move through the 
checklist. When the cursor is on the last page of a form, <PgDn> will display the next form in the 
Form Explorer checklist. If ProFile does not detect another form in the checklist, it will default to 
the next form that is ‘Used’ (either you have entered data in the form or it has a relevant 
calculation).  
 

 You can always access a form using the Form Explorer regardless of 
whether or not it is included in the processing checklist.  
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To move quickly to the top of the next form in the checklist, press <Ctrl+Alt+PgDn>. Likewise, to 
move backwards through the checklist, use <Ctrl+Alt+PgUp>.  
 
Remember, to use the checklist, you must select Options > Environment > Edit > Form Explorer 
Checklist.  
 

Keyboard shortcuts - Form Explorer  
 
Using a mouse is handy and does not require that you remember any special keystrokes. 
However, ProFile also provides keyboard shortcuts that will help you work more quickly. 
Keystroke equivalents to the mouse options are especially important if you process a large 
volume of files in a short span of time, as most T1 tax professionals do.  
 
This topic discusses the keyboard alternatives to the functions described on the preceding pages. 
Press <Tab> to move your cursor around the different areas of the Form Explorer. Press <Shift + 
Tab> to navigate in the reverse sequence. 
 

 To jump to a section in a form (where applicable), type the form name, forward slash and 

then the section number. 

 To open a form, type the form name and press <Enter>. You only have to type enough 

characters to make the form name unique. You can separate multiple form names with 

semi-colons.  

 If you have selected the ‘All’ tab in the Detail view, you can watch ProFile move the 

highlight bar to focus the search as you type.  

 To select a single page from a multiple-page form, type the form name, a hyphen and the 

page number. For example, to print the second page of the T1 jacket, type T1-2 and press 

<Alt+P>.  

 There are several function buttons at the top of the Form Explorer: Open, Print and New. 

Press <Alt> + the underlined letter of the button description (the hotkey) to ‘click’ the 

button. For example, press <Alt+P> to print the currently highlighted form(s).  

 To use the view buttons at the top of the Form Explorer, press and hold <Alt> and then 

the button hotkey. For example, to select the ‘List view’, press <Alt+L>.  

 To switch between category tabs, press and hold <Alt> and then the number of the tab. 

In 

 Press <Down Arrow> and <Up Arrow> to move the cursor through the form names. Press 

<Enter> to open the highlighted form.3 In ProFile T1, TP1 and T2, you can type a line 

number and press <Enter> to jump to that field in the return. You can also jump directly 
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to a field by entering the field code here. For example, T1.r[103] will take you to line 207 

on the T1 jacket.  

 

Print from the Form Explorer  
 
You can print a form (or a group of forms) by using the [Print] button options in the Form 
Explorer, simply click the [down arrow] to the right of the [Print] button.  
 
Several options appear; print the form, print the French version of the form, print the form with 
4 reduced-size pages per printed page (useful on multi-page forms such as the T1 jacket), and 
print the form with Review Marks.  
 
The language option is also associated with the [Open] button in the Form Explorer.  
 

Keyboard shortcuts  
 
If you process a large volume of client files, it is worth your while to learn the keyboard shortcuts 
for common functions in ProFile. You will find you can work much more quickly using the 
keyboard instead of the mouse. Refer to Appendix. 
 

Action Ctrl Key(s) Action Ctrl Key(s) 

Attach tape  <Ctrl+F8>  Open an existing file  <Ctrl+O>*  

Back to previous form  <Alt+F7>  Open form in new window  <Ctrl+Alt+F6>  

Carry forward a file  <Ctrl+R>  Open the Tape dialog box.  <=>  

Clear highlighter  <Ctrl+H>  Override format  <Ctrl+F2>  

Clear review mark on field  <Ctrl+Alt+0>  Partner sign-off  <Ctrl+Alt+2>  

Close current window  <Ctrl+F4>  Paste field  <Ctrl+V>*  

Copy field  <Ctrl+C>*  Pause / start timer  <Ctrl+T>  

Correction required mark  <Ctrl+Alt+3>  Preparer sign-off  <Ctrl+Alt+1>  

Create a new file  <Ctrl+N>*  Previous checklist form  <Ctrl+Alt+PgUp>  

Cut field  <Ctrl+X>*  Previous Forms window form  <Ctrl+Shift+Tab>*  

Display jump list  <Shift+F6>  Previous page on form  <Ctrl+PgUp>  

Display previous audit message  <Shift+F9>  Previous section on form  <Alt+PgUp>  

Ditto key  ` (back apostrophe)  Print file(s)  <Ctrl+P>*  
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EFILE this return  <Ctrl+F11>  Question review mark  <Ctrl+Alt+4>  

Instant SEND  <Shift+F11>  Quick-print audit messages  <Alt+F9>  

End review  <Ctrl+E>  Quick-print T1 summary  <Ctrl+Alt+F10>  

Exit ProFile  <Alt+F4>*  Quick-print T183 form  <Alt+F11>  

Explorer Keyword view  <Shift+F7>  Quick-print tax summary  <Alt+F10>  

Explorer Line view  <Shift+F4>  Save the file  <Ctrl+S>*  

Federal/Quebec toggle  <Shift+F5>  Show/hide auditor  <Ctrl+F9>  

File properties  <Ctrl+I>  Snapshot/Variance  <Alt+F8>  

Form help  <Shift+F1>  Switch to family member  <Alt+F5>  

Next checklist form  <Ctrl+Alt+PgDn>  T1, T2, T3 jacket  <Ctrl+J>  

Next Forms window form  <Ctrl+Tab>*  Toggle T1/TP1  <Shift+F5>  

Next file  <Ctrl+F6>  Toggle T2/AT1 RSI**  <Ctrl+F5> 

Next page on form  <Ctrl+PgDn>  Top of next slip  <Ctrl+Enter>  

Next section on form  <Alt+PgDn>  Top of previous slip  <Ctrl+Shift+Enter>  

Non-zero T1 summary  <Ctrl+F10>    

*Standard Microsoft® Windows® shortcut.  

**The federal RSI is now obsolete. Toggle between federal T2 forms and RSI view is valid only for modules 2006-2009 and earlier. 

 

The ditto key  
 
You can also use the ditto key on similar fields in a ProFile table. This is the backwards apostrophe 
key found in the upper left corner of most keyboards to the left of the number 1 key. Press the 
ditto key to copy and paste the contents of a similar field above or to the left of the current field. 
This is especially useful in tables when you have a long list of identical entries.  
 

Create or open a file  
 
To create a file, select File > New. If you have more than one ProFile application installed, you 
can select from different file types. ProFile will create a new file and open key forms where you 
can enter data. When you select File > Save, ProFile will automatically suggest a file name based 
on information you entered on the Information form (Info).  
 
To open a file, select File > Open or use the keyboard short cut <Ctrl+O>. You can also use Client 
Explorer to locate and open a client file.  
 

file:///C:/Users/Michael/AppData/Local/Temp/info_keyboard_shortcuts.htm%235c52e06
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1. Click a tab to select a ProFile module. Use the down arrow beside the tab to choose from 

different years (if applicable).  

2. ProFile includes full Windows compliant file dialog features such as file details, new folder, 

show desktop, etc... You can also right-click on file names to select normal Windows file 

operations.  

3. If you select ‘Preview file’, ProFile will display file information at the bottom of the dialog 

box.  

 

Reopen a file  
 
File > Reopen allows you to open files you have recently saved. The most recently saved files 
appear first in the list. You can change the number of file’s in this list by modifying Options > 
Environment > File > Recently used files.  
 

Options  
 

 Options > Environment > File > Multiple Open Files allows you to open any number of 

client files (including files from different modules) at once. Switch between them using 

the Form Explorer or the Windows menu.  

 Select Options > Environment > File > Save Desktop to store the status of your desktop 

when you save a file (including which tabs appear in the Forms window and the location 

of the cursor). You will return to the same place the next time you open the file.  

 Under Options > Environment > File > Default File Type, select the module you want to 

appear as the default (appear in front of the other tabs) on all Windows that show the 

ProFile module tabs, when you select File > New or use the shortcut <Ctrl+N>. The ‘Most 

Recently Used’ option means the default file type will change based on what module you 

last accessed.  

 Under Options > Environment > File > Recently Used Files, select ‘Attach to Reopen 

menu item’ to show the names of recently used files under File > Reopen. Select ‘Attach 

to File menu’ to show this list at the bottom of the File menu. Enter the number of files 

to display in this list. Press [Clear] to delete all entries from the recently used files list.  

 Go to Options > Environment > File > File Directories to select the ‘Lock’ option for a 

particular module to always default to that folder for that module in Windows dialog 

boxes (such as File > Open). If you clear the ‘Lock’ column, ProFile will remember the last 

folder you were in for a particular module in Windows dialog boxes.  
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Coupling T1 returns  
 
To take advantage of optimized spousal calculations in ProFile T1/TP1, you need to save both 
returns in the same file. I call joining two client files coupling and separating two coupled files 
uncoupling. Two returns stored in the same file are coupled and can share data with optimized 
calculations. 
 

Coupling T1 returns 
 

 Attention: If you have already saved the file before coupling the returns, 
the file name will include only the client’s name. Both returns remain stored in 
that file. You can rename the file during the coupling process to include the 
spouse’s name in the file name. 

 
To couple two returns: 
 

1. Open or create the file for the client.  

2. On the Info form, select either ‘Married; or ‘Living common-law’ for the marital status.  

3. Press <F5>, the function key to switch between spouse returns.  

4. Choose whether to create a new return for the spouse, or couple the file to an existing 

return.  

a. Select ‘Create a new return for spouse’, to open a new return for the spouse.  

 

 Attention: You must close the existing return before you can select to 
couple it to another. 

 
b. Select ‘Open an existing return’, to browse to a file on your hard drive and select 

it. 

  

 Note: After combining the data, ProFile will ask if you want to delete the 
original file for the spouse. Delete the file to avoid duplication or possible 
confusion of the original spouse’s file and the same return in the new coupled 
file.  
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5. Select File > Save. ProFile saves both spouses’ tax returns in the same data file. This allows 

you to keep the tax returns together as you perform file operations on the tax return file, 

such as backing up to a disk.  

 
Once returns are coupled, press <F5> to switch back and forth between the returns. 
 
On the database dialog (Other filter tab), select ‘Show spouse in list’ to show both the client and 
the spouse’s names. Clear this checkbox to show only the client’s name for each coupled file. 
 

Uncoupling T1 returns 
 
To uncouple a return: 
 

1. Open the coupled return.  

2. Select File > Uncouple and confirm that you want to uncouple the returns. ProFile 

automatically prompts you to save the spouse’s return in a separate file.  

3. Click <Save>. The client’s file keeps the coupled file name (for example, Couple, Joe and 

Thelma.T08). You can rename this file using the File > Save As option.  

4. On the Info form in each file, select ‘Widowed’, ‘Divorced’, ‘Separated’ or ‘Single’ for the 

marital status. 

 

Merging and separating - data flow when coupling and uncoupling returns 
 
ProFile handles the coupling and uncoupling process automatically. However, ProFile must make 
certain assumptions when merging data from two files. I recommend you review your files 
thoroughly after coupling or uncoupling returns. The situations below are examples of how 
ProFile handles information upon coupling or uncoupling returns. 
 

Dependants’ last name 
 
If you couple two returns, each containing dependant information, ProFile changes the 
dependants’ last name in the spouse’s return to the taxpayer’s last name. 
 

Example: Jason Travis has two sons, Joey Travis and Joachim Travis. Jason 
married Joanne Curtis who has her own daughter, Marla Curtis. When you 
couple the returns, ProFile merges Jason and Joanne’s Dependant worksheets 
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and gives them all Jason’s last name - Travis. In the coupled file, the Dependant 
worksheet lists Joey Travis, Joachim Travis and Marla Travis. You can override 
Marla’s last name directly on the Dependant worksheet to Marla Curtis, if need 
be. 

 
When you uncouple a return with dependants, all dependants appear in both uncoupled files. 
ProFile automatically gives them the same last name as the taxpayer. 
 

 Example: Jason Travis and Joanne Curtis divorced. They have three 
children: Joey, Joachim and Marla. When you uncouple their returns, Jason 
Travis’s Dependant worksheet shows Joey Travis, Joachim Travis and Marla 
Travis. Joanne Curtis’s Dependant worksheet lists Joey Curtis, Joachim Curtis 
and Marla Curtis. You can override any of their last names. 

ProFile retains any overrides of the dependant’s last name when you couple or 
uncouple returns. 

 

Dependants with the same first name and date of birth 
 
If you couple two files, each containing a dependant with the same first name and date of birth, 
ProFile considers these dependants as one person and only keeps the dependant originally found 
in the taxpayer’s file. 
 

Amounts transferred to a spouse 
 
Amounts transferred to a spouse remain in the return after you uncouple the file. Remember to 
review your file thoroughly after uncoupling returns. 
 

 Example: In a TP1 return, the TP1 Schedule B showed an amount on line 
58 (amount transferred to spouse for family tax reduction); that amount 
remains on line 58 even after you uncouple the returns. 

 
 
 
 



Chapter 6  Learning About Taxes with Intuit ProFile: 2016 TY 

35 

 

Forms  
 
In the Forms window you may enter information in fields, review all calculations and look at 
tables and graphs. A form may continue beyond the bottom of the screen and sometimes for 
several pages. Use the scroll bar on the right side of the Forms window to advance through the 
form.  
 
If a form is open, it appears in the Forms window and has a tab associated with it. To open a form, 
use the Form Explorer. To learn how to open forms from the same file in different Forms 
windows, see Windows.  
 
The Form Explorer and the Form menu provide access to all the forms. A client file is composed 
of all the forms that the client requires. As the software is form-based, you will enter client 
information directly on the ProFile forms.  
 
It is up to you to determine which forms are necessary for each client, based on the data you 
need to enter. You can find the forms you need as you are entering data in the return. If you 
prefer, you can identify all the forms you’ll need before you begin to enter information. To do 
this, use the Form Explorer checklist feature.  
 

Close a form  
 
To close a form, right-click and select ‘Close form’ from the context-sensitive menu or press 
<Esc>. To close a form, right-click on the form and select ‘Close Form’. This will not delete the 
form from the file, and it will not delete the data in that form. If you open the form, you will see 
the form is exactly as you left it (unless there have been calculations elsewhere in the file that 
affect that form).  
 
Options > Environment > File > ESC Closes Window closes the last form open in a file when there 
is only one form open in the Forms window. Clear this option and pressing <Esc> when there is 
only a single form open closes the form and displays a default form for that module. In the ProFile 
T1, this default form is the T1 jacket. 
  

Clear a form   
 
To delete any entries you made on the form, right-click and select ‘Clear form’ from the context-
sensitive menu.  
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Jump between forms  
 
Forms in the software flow data to other related forms. Numbers that appear in blue are fields 
calculated by the software. The calculation for the field may come from another form – if so, an 
up arrow displays in the status box of the field.  
 
To discover the source of data transferred from another form, right-click on the data field and 
select the context-sensitive link to open the source form. Choose any one of the listed forms to 
jump to that form. Select Form > Open when your cursor is on a field with a Jump indicator in the 
status box. ProFile will open the first form that is a source for the data in the field. You can see 
all the forms that are linked to the field when you right-click and display the context-sensitive 
menu.  
 
Pressing <F6> while on the field will jump directly to the first form on the context-sensitive list. If 
you select Options > Environment > Edit > Double Click Opens Links, you can also double-click 
on the field to jump to the first source form.  
 
If you right-click on a field and there is no link, then you must either enter this number yourself, 
or the calculation for that field is derived from data elsewhere on that same form.  
 
In tax modules, the Goto menu gives you shortcuts to the forms accessed most frequently. Click 
on a form name to open that form in the Forms window.  
 

Back track  
 
As you enter data in a client file, you will move frequently from one form to another. Choose 
‘Back track’ from the Form menu or type <Alt+F6> to return to the form you were editing 
immediately before moving to the current form. 
  
This option differs from the Previous form option in the Goto menu. Previous form ignores your 
navigation between forms and takes you to the form that is prior to the current form in the 
processing sequence. You can see the form processing sequence in the Detail view of the Form 
Explorer, below the Step column.  
 

Zoom into a Form 
 
To zoom in on a form to make it easier to read (especially on a small screen), select Form > Zoom. 
 
To return to the regular view, select Form > Unzoom. 
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Page up and page down  
 
ProFile offers a number of keystrokes that help you move between forms in the Forms window:  
 

 <Ctrl+PgDn> moves to the next page in the current form. At the end of the form, ProFile 

will open the next form used in this file.  

 <Ctrl+PgUp> moves backward through the pages of the current form and then on to the 

immediately preceding form.  

 <Ctrl+Alt+PgDn> or Goto > Next form opens the next used form into the Forms window.  

 <Ctrl+Alt+PgUp> or Goto > Previous form opens the previous used form.  

 Select Options > Environment > Edit > Continuous forms to use <PgDn> and <PgUp> 

instead of <Ctrl+PgUp> and <Ctrl+PgDn> to move through the pages of the current form 

and then onto the next or previous form.  

 
All the above shortcuts take into account the Form Explorer Checklist if you have selected forms 
that you wish to include in the file.  
 

Jump to the spouse return  
 
Select Form > Spouse to switch back and forth between the returns for a client and spouse. 
ProFile saves spousal returns in the same data file. When you are working on coupled returns, 
however, only one is open in the Forms window at any particular time. Press <F5> or choose 
‘Spouse’ from the Form menu to display the return for the other spouse.  
 

Unlimited ‘#’ forms (multiple copies of forms) 
 
Some forms can have unlimited copies, such as the T2125 (business statements) in ProFile T1. 
These forms have a ‘#’ sign behind the name in the Form Explorer (T2125#). There are two ways 
to create additional copies of these forms:  
 
In the Form Explorer, highlight the form name and click the [New] button.  
 
If the form is active in the Forms window, right-click and select ‘New form’ from the context-
sensitive menu. If you wish to remove one of these forms from the client’s data file, go to Form 
> Delete Form from the menu.  
 

 You must have at least ONE of each of these forms in the software at all 
times. So, for example, you cannot delete ALL the Loan forms. If the data in the 
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last remaining form is irrelevant, simply use the Clear form function from the 
Form menu.  

 

Enter data  
 
Forms are a collection of text, graphics, data fields and interactive graphs. 
  
There are several types of data fields, and some that are calculated by the software can be 
overridden. A data field may have a black status box to the right. You can copy the contents of a 
data field to another by using drag and drop. You can use this method to monitor fields at the 
bottom of the screen. predictive typing saves you time on text fields (such as donations) by 
‘guessing’ what you want to enter after you type a few keystrokes.  
 
Try drawing on the screen with the right-mouse button highlighter. Leave yourself, your partner 
or a reviewer a message by attaching a memo to the field. You can also attach a calculator tape 
to a field.  
 

Override  
 
The software performs many automatic calculations. If you encounter a situation that requires 
figures different from the automatic calculations, you may override the calculated number with 
your own data.  
 
Some overrideable fields are calculated directly on the form where they appear. For example, 
the sum of a list of numbers. However, there are fields that are calculated on other forms. To 
help you find out where ProFile calculates an amount, right-click on the field. Then, select the 
‘Source’ form from the context-sensitive menu. The new form will open with your cursor at the 
point where the number was originally calculated. If multiple form names appear in the context-
sensitive menu, the field value derives from all these forms.  
 

 When you need to enter data that does not match the usual format for a 
field, you can use the ProFile format override. <Ctr+F2> will let you enter a 
differently formatted value, for example, a zip code in a postal code field.  
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Status box  
 
You can tell the difference between the two types of overrideable fields by looking at the status 
box. If there is an up arrow in the status box, the number is calculated on another form. If not, 
the number is calculated on the current form.  
 
A red diamond appears in the status box to show that you have overridden the automatic 
calculation. For example, Pensionable Earnings from a client’s T4 slip may not match the value 
ProFile calculates.  
 

Automatic override  
 
If you select Options > Environment > Edit > Automatic override, you can override a calculated 
field simply by typing a new number.  
 

If you clear Options > Environment > Edit > Automatic override, you will need to press <F2> 
before entering your number.  
 
To help you from inadvertently overriding numbers, select Options > Environment > Edit > 
Audible Override and ProFile will make an unobtrusive noise when you override a field.  
 

Restore the automatic calculation  
 
Any of these options will restore the automatic calculation:  
 

 Press <F2> while on the field  

 Right-click on the field and select ‘Override’ from the context-sensitive menu  

 Select Edit > Override from the menu system  

 

Override audit messages  
 
As a precaution to help prevent accidental overrides, fields containing overrides will be listed in 
the Active Auditor Summary tab (if you have selected Options > Environment > Audit > Summary 
tab includes > Overrides).  
 

Predictive typing  
 
Predictive typing saves time by reducing the number of keystrokes you need to type in repetitive 
text fields. Similar text fields in a ProFile module share a predictive typing list that grows as you 
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enter data in your client files. When you enter text into a field, ProFile tries to ‘guess’ what you 
are typing based on previous entries in the field.  
 
For example, how many times in a year do you type ‘Royal Bank’ on the T5 slip descriptions? With 
predictive typing, you need only enter ‘Royal Bank’ once. The next time you go to the T5 slip form 
(for any taxpayer) and type ‘R’, ProFile will assume you mean ‘Royal Bank’ and will complete the 
field for you. If it is not ‘Royal Bank’, simply keep typing to enter your new text.  
 
Predictive typing is available for most text fields, such as slip names, medical expenses and 
charitable donations. There is a separate list for each form so that only relevant entries will 
appear as you type. All your client files share these lists. 
  

Typing lists  
 
ProFile maintains many predictive typing lists for the many different forms. For example, the list 
for T5 slip names is separate from the list for donation names. This ensures that the guesses 
always make sense. The typing lists are available from any client file.  
 
To see all the entries in the predictive typing list for a field, right-click on a text field and select 
‘Typing List’. You can also press <Ctrl+Down Arrow>. Use the mouse or the up and down arrows 
on your keyboard to move through the predictive typing list.  
 
Predictive typing lists allow 250 entries for each list (a single list applies only to logically related 
fields in the software). However, you can set the size of the typing list (in other words, the total 
number of items that the list can include for each field) under Options > Environment > Edit > 
Predictive typing > Maximum Entries.  
 
By default, ProFile sorts the predictive typing lists into a most-recently used order. If you prefer 
alphabetic order, select Options > Environment > Edit > Predictive typing > Sort items.  
 

Delete an entry on the list  
 
To delete an entry from the list:  
 

1. Right-click on a text field and select ‘Typing List’ or press <Ctrl+Down Arrow>.  

2. Highlight the entry using the cursor keys.  

3. Press <Ctrl+Delete>.  
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Disable Predictive typing  
 
If you do not want to use predictive typing, clear Options > Environment > Edit > Predictive typing 
> Enabled.  
 

Drag and drop  
 
To copy data from one field to another, you can use a technique known as ‘drag and drop’. You 
can drag information from one field to another by ‘clicking and holding’ then ‘dragging and 
dropping’.  
 
Move your cursor to a field, then click and hold the mouse button. After a brief pause, the cursor 
will change to show that it has ‘picked up’ the data from the field. Move the cursor to another 
field (drag it) and then release the mouse button (drop it). The new field will now show the copied 
data. 
 

 If the destination is a matching type of data field, the contents of the first field will copy 

to the second.  

 If the destination is either the Data Monitor or the Word Processor, ProFile will copy the 

field code rather than the field contents.  

 
You can use this technique to monitor data fields at the bottom of the screen, or to drag field 
codes onto a word processing template.  
 

Form Copy/Paste  
 
When you need to create another copy of a form you have already completed, use the Copy and 
Paste function to save time. For example, in ProFile T1 you may be completing business or rental 
statements for non-spousal partners. You do not have to re-enter the same business data in both 
files.  
 

1. Complete the form in one client file.  

2. Copy the form using Edit > Copy Form.  

3. Open the data file for the partner.  

4. Open a blank copy of the same form in the partner’s file.  

5. Select Edit > Paste Form.  

6. Edit the form as needed for this client.  
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Intuitive Copy/Paste  
 
The ProFile business statements include a section for Details of other partners. For each partner 
you will enter the name, social insurance number and percentage of share in the partnership. 
Once you finalize all the business statement data, use Edit > Intuitive copy form to copy all the 
business statement data. Then use Edit > Intuitive Paste to paste the data onto the business 
statement in the partner’s tax return file, ProFile automatically adjusts all amounts and the 
details of other partners to complete this form correctly for each partner. In fact, even the 
attached memos and tapes copy to the next business statement!  
 

Unlimited slips  
 
There is no limit to the number of information slips you can enter in your client files. In ProFile 
T1, this means unlimited T3s, T4s, T5s, etc. Unlimited slips are completely automatic—as soon as 
you enter information in the last available slip, ProFile will give you another slip to use.  
 
To handle large volumes of Employee slips in ProFile FX the slip interface has one additional 
feature. A sidebar list organizes slips alphabetically. You can sort and search the list quickly when 
you need to modify an employee slip.  
 

1. With your mouse, use the horizontal scroll bar at the top of the slip table to scroll through 

the slips.  

2. To insert or delete a slip, right-click on a column and select the appropriate option from 

the context-sensitive menu.  

3. Slip descriptions use the ProFile predictive typing feature.  

4. To scroll through the slips with your keyboard, use <Alt+Left Arrow> and <Alt+Right 

Arrow>.  

 

 Hint: To move quickly to the top of the next slip, press <Ctrl+Enter>. To 
move quickly to the top of the previous slip, press <Ctrl+Shift+Enter>.  

 
When you delete a slip, ProFile automatically renumbers the remaining slips. Slips are always 
numbered consecutively, without gaps.  
 

Expandable tables  
 
Throughout the ProFile software there are expandable tables that allow unlimited entries. 
Expandable tables hold a great deal of your client information. These tables grow automatically 



Chapter 6  Learning About Taxes with Intuit ProFile: 2016 TY 

43 

 

as you enter data, giving you extra blank rows and columns as you need them. As soon as you 
enter information in the last available row, the table expands to give you another line where you 
can enter data. This feature is similar to the tables for unlimited slips and the multiple-copy forms 
described in the next section.  
 

1. When you enter data in any of the fields in the last available line, ProFile will add another 

blank line to the table.  

2. To insert or delete a row, right-click on a row and select either option from the context-

sensitive menu.  

3. On some tables, you can right-click for options specific to the table. For example, on the 

Donations table, right-click to sort the donations alphabetically.  

4. Enter a description once, and then use the ProFile predictive typing feature to select that 

description next time you need it.  

 
You can see expandable tables in ProFile T1 on the Medical expenses form. In ProFile T2, Schedule 
6, Dispositions of capital property is an expanding table.  
 

Exchange rates  
 
ProFile includes average annual Bank of Canada exchange rates for each calendar year. ProFile 
uses these averages to convert foreign currency to Canadian currency when a taxpayer has 
received foreign and other amounts throughout the year and has not kept a record of the 
Canadian dollar equivalent received on conversion of those amounts. 
 

Share data  
 

The ProFile technology helps you to re-use your client data, and even to create new files based 
on data from other programs you use.  
 
Data integration between ProFile modules or between ProFile and other software programs will 
improve your efficiency and accuracy. You’ll save time by entering information once and re-using 
it for other purposes. You can also avoid new data entry errors by re-using verified client 
information.  
 
Here are some of the options for data transfer using the ProFile technology:  
 

 Create a new FX file in ProFile based on data from a T1, T2 or T3 return.  

 Create a new T3 file in ProFile based on data from a T1 return. 
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 Link the T1 or T1/TP1 files of family members to automatically transfer credits and 

amounts to carry forward.  

 Create a new T1 or T1/TP1 file for a family member, based on Dependant information 

entered in the file of the supporting taxpayer.  

 Transfer data from a T1 tax return to the Tax Planner to create different plan scenarios.  

 Copy business statements between the T1 tax returns of different partners in the 

business.  

 Import GIFI account information into a ProFile T2 file.  

 Export information from any ProFile data fields in a standard text (TXT) file that you can 

import into Microsoft® Excel, for example.  

 Use the ProFile Software Development Kit (SDK) to write custom applications that will 

extract data automatically from ProFile data files, or create new ProFile files using data 

exported from another software program. Even more, your custom applications can 

access the calculations within ProFile and use these in processes to automate data 

treatments outside ProFile.  

 

Audit and review  
 
When it comes time to verify the data you have in each client file, ProFile has the tools to make 
your review painless.  
 

Review: Step-by-Step  
 
The ProFile software includes many features designed to help you ensure that your work is 
accurate and of the highest quality. If you take advantage of these features, you can develop a 
review process that will reduce errors and oversights in your file preparation.  
 
Here is an example of a quality assurance process you might wish to use for your T1 tax return 
preparation. Most of the audit and review features are available in all the ProFile modules.  
 

1. You begin by carrying forward a coupled client file from the previous year.  

2. You enter slips and other information from the current year, making adjustments when 

the Passive Auditor indicates a possible error.  

3. Using ProFile variance detection, you can see immediately which fields show significant 

differences from the past year values. You can review these fields to make sure the 

difference from last year is valid.  
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4. In the data monitor you keep an eye on the bottom-line tax payable for each client. You 

experiment using the right-click transfer feature for claims (donations or medical 

expenses) that either spouse can make. You use the right-click optimization feature for 

getting the best claim from a number of medical expenses dated during the past two 

years.  

5. As you enter data, you attach memos to fields that still require attention, for example, if 

the client is still waiting for a final T4 slip.  

6. You save the file and update the client status to indicate that work is still in progress.  

7. During your next session, you review diagnostic messages in the Active Auditor by 

pressing <F9> repeatedly to check the diagnostic messages one by one. The Summary tab 

of the Active Auditor is your customizable checklist for items of concern in the client file.  

8. When you discover a field that produces a diagnostic but you know the entry is correct, 

you mark the field with your preparer sign-off review mark to indicate that you have 

resolved the diagnostic.  

9. You update the Client status to in partner review, and a senior partner in the firm goes 

through the file for any unresolved diagnostics. 

10. When you attempt to print the completed file, you notice a prevent filing warning that 

tells you that you have missed an important diagnostic in the Active Auditor. You discover 

a memo reminding you to confirm with the client that you have all T4s for the year, so 

you call to confirm, then clear the diagnostic with a sign-off.  

11. You print and file the return. Because you have set the data locking option for all printed 

files, you know there will be no accidental changes to the finished file.  

  

Review marks  
 
Preparer review marks allow you to communicate easily with other preparers, assistants and 
partners and leave reminders for yourself. You can use a combination of review marks and 
memos to leave reminders about unfinished processing issues (for example, ‘Taxpayer needs to 
provide employment expense slips’). 
 

 
 

To add review marks to a single field: 
 

 Right-click in a field, point to Review marks, and choose a review mark (such as Preparer 

Sign-off or Partner Sign-off). 
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 Tip: Press <Ctrl+Alt+#> (where # is a number key from 0 to 4) to add a 
review mark to the currently-selected field. 

 

To add review marks to several fields at once: 
 

1. On the toolbar, click a review mark button (such as Preparer Sign-off or Partner Sign-off). 

The cursor changes to indicate that you are in Review Mode for the selected type of 

review mark. 

 

 Tip: Press <Ctrl+E> to activate or de-activate the Preparer Sign-off Review 
Mode.  

 
2. Click a field. The review mark attaches itself to the field’s status box. 

You can mark as many fields as you want. You can switch between different review marks 

by clicking different review mark buttons. 

3. To leave review mode, click the currently-active toolbar review mark button again. 

 

To add a review mark from the Active Auditor: 
 

 In the Active Auditor pane, right-click a message and choose a review mark (such as 

Preparer Sign-off). ProFile adds a review mark to the field. 

 

 Tip: When adding a review mark from the Active Auditor, ProFile does not 
open the form. This lets you quickly mark a set of Audit messages for attention, 
regardless of where they occur. 

 

To clear review marks in a form: 
 

1. If necessary, open the desired form in the Forms window or click its tab. 

2. Go to the Form menu and click Clear review marks. 
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To include review marks in a printed copy of a form 
Do one of the following: 
 

1. Go to the File menu and click [Print]. 

2. In the Print Selection window, within the Print Details section, click to select the 

‘Review marks’ boxes for the form sets for which you want to include Review 

marks. 

For example, to include review marks in printed copies of forms in Set 1, click the 

‘1’ checkbox in the Review marks row. 

or 

 In the Form Explorer (F4), select the form you want to print. Click the [down arrow] to 

the right of the Print button and choose ‘Review marks’. 

  

Use the Summary tab as a checklist  
 
By default, the Summary tab is designed to work as a checklist that updates automatically as you 
review a file. When using review marks, press <F9> to look through the list in the Summary tab 
one item at a time. For each listed field, the reviewer selects the appropriate review mark. 
  
To use the Summary tab as a checklist for outstanding items in your client returns, I recommend 
you set and clear the following options: 
 

1. Go to the Options menu and select ‘Environment’, then select the ‘Audit’ tab. 

2. To remove audit messages from the Summary tab during a preparer or partner sign-off 

review, in the Remove Audit Messages section, click to clear the On Preparer Sign-off or 

On Partner Sign-off checkboxes. 

3. To remove messages about Preparer or Partner sign-off review marks from the Summary 

tab, in the Summary Tab Includes section, clear the Preparer Sign-off and Partner Sign-

off boxes. 

 
Using the above options, ProFile clears messages from your list of outstanding items as you sign 
off on fields with attached review marks (that is, the Summary tab displays only messages that 
have no sign-offs). Messages with sign-off marks still appear under the Sign-offs tab, so you can 
always double-check your work. 
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 Tip: To help you review, you can print an Audit Summary from the Form 
Explorer. The types of messages on that report can match the Summary tab of 
the Active Auditor, or may include different message types. 

 

Audit Messages  
 

Passive Auditor  
 
ProFile includes extensive audit messages that are triggered by the data you enter (or omit) in a 
client file.  
 
The Passive Auditor checks the file ‘in the background’ as you enter data. When the Passive 
Auditor detects a possible error, a yellow highlight appears on the field that may be incorrect. 
Move your cursor over the field to see the message. This feature alerts you to potential problems 
as they arise so you can deal with them right away.  
 
The Passive Auditor can catch many different processing errors, and even suggests advantageous 
claims you may not have considered.  
 

 Missing data that is necessary for filing  

 Missing data that is needed to EFILE (if a return is selected for EFILE)  

 Amounts reported on slips that are not within the tolerance range for the amount 

expected  

 Opportunities for additional claims (for example, taxpayer may be eligible for disability 

amount)  

 Claims that may be more optimal on the spouse’s return  

 Filing requirements specific to the return (for example, taxpayer is subject to minimum 

tax)  

 Option to reduce deductions/credits that are not usable in the current year and that can 

be carried forward to next year (for example, RRSP deduction or CCA on business 

statements)  

 Planning opportunities  

 Other forms or elections that may be necessary but are not included in the T1 (T1-OVP 

must be filed).  

 
Move your cursor over a yellow field. ProFile will display the audit message in a pop-up window. 



Chapter 6  Learning About Taxes with Intuit ProFile: 2016 TY 

49 

 

 

 Field backgrounds can display several different colours. White means there 
is no additional information associated with the field. Yellow indicates a Passive 
audit message. Green means a calculator tape or memo is attached. Orange 
means a variance message is attached. Red tells you that you’ve entered invalid 
data and must correct it before leaving the field. The yellow Passive audit 
message takes precedence over the other types in cases where multiple 
messages apply to the same field.  

 

Active Auditor  
 
The Active Auditor displays a list of audit messages that apply to the return or data file. These 
include passive audit messages, notices, processing errors, fields that have been overridden, 
fields that have memos attached, fields with review marks and EFILE messages. Active Auditor 
messages are sorted into tabs based on type. 
 
There are several ways to display the Active Auditor: 

 

 Click the [Active Auditor] toolbar button ( ). Click it again to quickly hide the Auditor.  

 Go to the Audit menu and choose ‘Show Auditor’ 

 Right-click in a form and choose ‘Show Auditor’ 

 Press F9.  

 

Working in the Active Auditor 
 

 To adjust the height of the Active Auditor, click and drag the separator between the Active 

Auditor and the Forms window.  

 To jump to the field associated with an audit message, double-click the audit message.  

 To jump to the next audit message, press F9 (or go to the Audit menu and choose ‘Next 

Audit Message’).  

 To return to the previous audit message, press <Shift+F9> (or go to the Audit menu and 

choose ‘Previous Audit Message’). 

 To toggle display of the Active Auditor on and off, click the [Auditor] toolbar button again 

or press <Ctrl+F9>. If you save a client file while the Active Auditor is active, it appears 

again when you next open the file.  
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Printing audit messages 
 
To print Audit messages, open the Form Explorer <F4>. In the Client category, you’ll find the Audit 
Summary report. In the Form Explorer, right-click the Audit Summary and choose ‘Print’.  
 

 Tip: To specify the types of messages included in this report, go to the 
Options menu and select ‘Environment’, then select the ‘Audit’ tab. Select or 
clear the checkboxes in the Audit Summary Includes section as desired.  

 
The Audit Summary report is available only for printing. It cannot be displayed in the Forms 
window; use the Active Auditor instead. 
 

The Active Auditor Summary tab 
 
By default, the Summary tab contains all audit messages except for Preparer Sign-off and Partner 
Sign-off messages. To change the messages that appear in the Summary tab, go to the Options 
menu and choose ‘Environment’, select the ‘Audit’ tab, and specify the desired types in the 
Summary Tab Includes section.  
 

Configure the Active Auditor  
 
The Summary tab is customizable so that you can create your own review process. It may include 
all the different audit message types, or only the categories of messages you select. The Summary 
tab can work as your checklist in the review process.  
 
You can define the types of audit messages that appear on the Summary tab by selecting 
properties under Options > Environment > Audit. No matter which options you select here, an 
audit message will ALWAYS appear on the tab that matches the message type (assuming you 
display all the Auditor tabs). For example, if you added memos to some fields, ProFile lists these 
fields on the Memo tab of the Active Auditor. You may choose to display these memo fields on 
the Summary tab as well, if you want to be sure you don’t miss messages of this type in your 
review of the file.  
 

 Under the heading, Preferences, Circle Fields will use the ProFile highlighter with the 

Active Auditor. When you double-click an Auditor diagnostic, the highlighter circles the 

related field in the Forms window. Show Auditor Tabs displays the diagnostics by category 

(as well as on the Summary tab) in the Active Auditor.  
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 Select the types of messages you want to display on the Summary tab. Remember, even 

if you omit a particular message type on the Summary, it will still appear under the 

separate category tab for that type of message.  

 You can also specify what types of messages will print in the Audit Summary that you can 

print from the Form Explorer.  

 If you select ‘Prevent Filing’ options, ProFile will display any outstanding Summary tab 

messages before it allows you to print (or EFILE a tax return). For example, you may want 

a senior preparer to sign-off on all overrides or memos before anyone prints the file.  

 Select the sign-off options if you want the preparer or partner review marks to remove 

diagnostics from the Summary tab. You can still view messages you have cleared from the 

Summary tab. A preparer sign-off can remove a memo message from the Summary, but 

you can still see the message on the memo tab, and on the preparer sign-off tab. 

 

 Hint: If a file contains particular types off messages, you may want to see 
a warning before you print or EFILE. Select from the ‘Prevent Filing’ option list 
under Options > Environment > Audit. Audit messages selected to prevent filing 
appear in red in the Active Auditor. To clear the message, you can resolve the 
condition that triggers the message. Alternatively, (if the ‘Remove 
diagnostic/notices’ option is selected) a preparer or partner can attach a sign-
off review mark to the field. In the Active Auditor, Prevent Filing messages 
appear in red.  

 

Audit message types  
 
ProFile provides a variety of diagnostic messages. These messages are separated by type on the 
different tabs of the Active Auditor (Options > Environment > Audit > Show audit tabs). You can 
customize the Summary tab to include any type of audit message you want. Select the types 
under Options > Environment > Audit > Summary tab includes.  
 
When your window is not wide enough to display all the tabs in the Active Auditor, ProFile will 
provide horizontal scroll arrows to access the remaining tabs.  
 

 Warning messages alert you to potential processing problems. They signal you to data 

you may have overlooked or entered incorrectly in the client file. You can usually 

eliminate warnings by providing missing information or correcting data entry errors. 

These are the same messages that appear as yellow passive audit pop-ups in the Forms 

window.  
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 Notices alert you to key dates or steps you may need to take as a result of calculations 

specific to this client file. They usually indicate a processing or filing requirement. Usually, 

you cannot make a change to the client file to eliminate a notice, they are simply 

reminders for you to consider.  

 The Sign-offs tab shows the fields that have partner or preparer review marks, indicating 

that a preparer or partner has confirmed the value that appears in a field.  

 The Issues tab displays fields that have correction or question review marks. Use 

correction marks for incorrect fields when you do not yet have the information you 

require to fix the entry. Use the question mark for fields that require further investigation.  

 The Overrides tab includes every field that has an override amount rather than an 

automatic ProFile calculation. At the end of each override message, ProFile displays the 

amount that the software would calculate automatically, if you removed the override 

from the field.  

 The Memos tab shows all fields with Memos attached.  

 The EFILE tab lists errors for T1 EFILE/SEND and T2 Corporation Internet Filing. The tab 

lists two types of electronic filing messages: those that ProFile detects, and others 

generated by the CRA and returned in the acknowledgement file.  

 The EDI lists errors for TP1 NetFile.  

 The Carryforwards tab lists all the fields containing information carried forward from the 

previous year’s return. These amounts appear in purple on the forms. In ProFile T2 and 

ProFile FX fields with imported data also appear on the Carryforwards tab.  

 The Tapes tab shows all fields with Tapes attached.  

 The Variance tab lists all the fields in the current return that are different than the return 

in the snapshot.  

 The Magnetic media tab lists all the messages related to building disk files of federal and 

provincial slips for submission to CRA or RQ.  

 

Prevent filing audit messages  
 
When you try to print or build an EFILE file, ProFile can display a list of audit messages. You can 
click [Cancel] and resolve the issues before printing OR click [OK] to continue. This allows you to 
follow strict quality control procedures and prevents you from inadvertently submitting a return 
that still has unresolved diagnostics.  
 
Select the types of audit messages that trigger a warning when you try to print or build an EFILE 

file under Options > Environment > Audit > Prevent filing.  

 

file:///C:/Users/Michael/AppData/Local/Temp/work_enterdata_override.htm
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At the very least, you will probably want to prevent filing if there are outstanding Memo or 

Correction mark diagnostics. Your memos will often flag fields that require further attention, and 

correction marks indicate that you have a concern about some information in the file.  

 

Variance 
 
Variance is a feature that you can use to identify significant changes on the T1/TP1, T2, and T3 
jackets, schedules or T1Cs. Snapshot variance lets you experiment with different scenarios™ and 
quickly identify the impact of a change on many key fields. Variance is only calculated for fields 
with CRA line numbers. So, some fields (for example on worksheets) will not be included in the 
variance comparison. 
 

 Hint: You can also have ProFile automatically take a snapshot when you 
print or create a PDF file. Simply select the ‘Take snapshot’ option on the print 
dialog before you click [Print]. In addition to Snapshot variance, ProFile includes 
Previous year variance to identify significant differences between returns of 
different years.  

 
To take a snapshot of your current return:  
 

1. Select Audit > Snapshot/variance and click on the [New] button. This will take a picture 

of the current contents of the tax return.  

2. Give the snapshot a name that will remind you of the purpose of the scenario.  

3. Select the ‘Activate this snapshot’ option to have ProFile compare any changes you make 

in the file to this snapshot and click [OK]  

 
As you make changes in the file, you can see the variance analysis on the Variance tab of the 
Active Auditor, <F9>, and in ‘fly-over’ messages when your cursor is over a yellow variance field. 
The Line number view of the Form Explorer lists all the fields that can show variance amounts.  
 

Shelf-life of a snapshot  
 
Snapshots may have a short self-life. For example, you may have created a snapshot last week 
using a client RRSP contribution of $5000. This week you may want to evaluate the impact of 
reducing that contribution to $3000. However, if you also added a new T3 slip since taking the 
first snapshot, variance will detect the impact of both the T3 and the RRSP contribution change. 
To best use variance, make sure you manage carefully which data fields you’ve changed since 
taking a snapshot that you want to use for comparison. 
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Deleting a snapshot  
 
Snapshots may have a short shelf-life. If you change other data in the return, like adding income 
from a forgotten contract job, you will need to delete your original snapshot and create a new 
one, reflecting the extra income, before comparing that scenario to current data.  
 
On the Snapshot Variance dialog, Audit > Snapshot Variance, select a snapshot that you no 
longer need and click the [Delete] button to remove that snapshot.  
 

Previous year variance  
 
For any files that you carry forward in ProFile T1/TP1, you can also use the variance feature to 
compare values in the current year’s tax return with values in the previous year. When you carry 
forward a return, ProFile automatically creates an entry for the previous year in the Snapshot / 
variance dialog box. Simply activate the previous year to see variance notices on the Variance tab 
of the Active Auditor and in ‘fly-over’ messages when your cursor is over orange variance fields.  
 

Variance thresholds  
 
You can set variance thresholds to meet your own requirements. Under Options > Module > ... 
> Variance, set a minimum dollar value or percentage of change that will trigger a variance 
calculation. If you set both a dollar and a percentage amount, ProFile calculates a variance only 
when the amount differs by more than the dollar value and the minimum percentage. You can 
also set a variance threshold specifically for the T1/TP1 Review under Options > Module > ... > 
T1/TP1 Review. 
 
You can use the variance function to automatically complete T1-ADJ forms. Create a snapshot, 
enter the new data and right-click on the table on the T1-ADJ form.  
 

Data locking  
 
Data locking options ensure that you do not accidentally modify a client file that is currently 
undergoing review or that you have already submitted to the CRA. All fields on data locked 
returns are green and non-edit.  
 

 Data locking does not apply to the Tax Planner or the adjustment forms in 
ProFile T1/TP1.  
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Automatic data locking  
 
Using the data locking feature you can prevent changes to your completed client files.  
 
You determine what status of files you want to lock, and configure your selections independently 
for each ProFile module. For example, in ProFile T1 you can use the EFILE status settings as well 
as the Client status settings to lock all the files at a particular stage of processing. Users will be 
unable to modify files that saved with the data locked status setting.  
 

 Automatic Data locking depends on file status flags to determine which 
files are locked, and which are not. To use this feature you need to update the 
status for each file when you save to reflect stage of processing.  

 
To prevent unintentional changes to a completed file:  
 

1. Go to Options > Module > Data locking.  

2. Choose which file statuses will lock data. For example, choose ‘Completed’ for the ‘Client 

Status’.  

3. When you have filed a tax return, change the Client Status to ‘Completed’ under File > 

Properties.  

 

 You can also lock a file manually using the ‘Locked’ checkbox on the File > 
Properties dialog.  

 

Preparer information  
 
Enter the preparer and firm contact information on Options > Environments > Preparer. ProFile 
transfers this information automatically to the letters and completes the Info form based on the 
settings of the workstation where a new file is created.  
 
ProFile can lock Preparer information that appears on the Info form. The information for the 
original preparer of the file travels with the file so that you can keep a record of the ‘file owner’ 
as it passes through the review process. If you need to update the preparer information to match 
the configuration at a different workstation, right-click and select ‘Update preparer information’.  
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Under Options > Module > General, you can choose to have ProFile to update preparer 
information to match the configuration for any workstation where the file opens.  
 

Data locking example 
 

Example  
Rate changes in the tax modules are occasionally implemented retroactively. If you open an 
already filed return (without data locking turned on) in a version of ProFile containing these new 
rates, the file is recalculated. Use data locking not only to protect the data as filed but also to 
help you determine how a rate change affected clients:  
 

1. Open the locked file in the new version. All fields appear green and are non-edit.  

2. Select Audit > Snapshot/Variance and take a snapshot of the file. Give it a name you will 

recognize. Activate this snapshot  

3. Go to File Properties and clear the Locked checkbox at the top right of the dialog box and 

click [OK].  

4. ProFile recalculates the file based on the new rates.  

5. Variance highlights any fields that have changed in orange.  

6. Review the changed fields in the Variance tab of the Active Auditor to determine whether 

or not the rate changes benefit the client.  

 

Save and close a file  
 
To save a file, select File > Save or File > Save As or press <Ctrl+S>.  
 

File Naming  
 
When you are save the file for the first time, ProFile bases the file name on data you entered in 
the Info form.  
 
By default, ProFile T1 saves the file using the client name(s). If you would like to include the SIN 
in the filename or use only the SIN, change the File name setting under Options > Module > … > 
General.  
 
Select Options > Environment > File > File Protection to check the file database when you create 
and save a new return and to verify that you have not already created a file with the same SIN, 
Trust or Business Number.  
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File Location  
 
Go to Options > Environment > File > File Directories to set the default folders for saving files for 
a particular module. Click on row under the ‘Directory’ column to enter the name and pathway 
to the default folder for saving files for a particular module. Click the [...] button to browse for 
the folder.  
 
Select the ‘Lock’ option for a particular module to always default to that folder for that module 
in Windows dialog boxes (such as File > Open). If you clear the ‘Lock’ column, ProFile will 
remember the last folder you were in for a particular module in Windows dialog boxes.  
 
By default, ProFile saves files in the Windows ‘My Documents’ folder, in a folder called ‘My ProFile 
Data’.  
 

File > Save As and File > Properties  
 
File > Save As and File > Properties are custom dialog boxes that include extra functions. For 
example, you can maintain file status settings from these dialog boxes.  
 
Options > Environment > File > Save prompt will display the File > Properties dialog box each 
time you choose File > Save or File > Save As. This will allow you to change status flags and other 
tax-related features attached to the data file. If you do not select this option, ProFile will display 
the standard Windows dialog box when you select File > Save As and will save without opening 
a dialog box at all when you select File > Save or press <Ctrl+S>.  
 

 Use the Client status drop-down list to select the stage of processing. For example, is this 

file Complete, or is it still Work in process? When you keep status flags up-to-date, you 

can use them in the Client Explorer or the Classic Database. The status settings are 

available as filters to help you narrow your search through all the records. Status flags 

work independently for spousal tax returns.  

 If Options > Environment > Edit > Use timer is on, ProFile will keep track of how long 

you’ve worked on the file. The time is cumulative and you can use the time log to bill by 

the hour on the Billing form in ProFile T1/TP1.  

 By default, ProFile will use the preparer and partner initials entered under Options > 

Environment > Preparer.  

 This History list shows the activity of the file and the preparer initials from each 

workstation where the file was modified.  

 If you select Options > Environment > File > Allow password, you can enter a password 

(and confirmation) here. Once you close the file, you cannot open it again without 

supplying the password.  
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 Change the name of the file or save it to a different drive/folder. When you rename a file, 

ProFile copies the file under a new name. The original file using the old name will remain 

until you delete it. You can easily identify and remove that file using File > Delete.  

 Select Options > Environment > File > Discounter Info Dialog to expand by default the 

Discounter section on the File > Save as and the File > Properties dialog boxes. You can 

still use the [Advanced] button on those dialog boxes to show or hide fields for Discounter 

information.  

 

Close a File  
 
To close the current file, select the File > Close command or use the <Ctrl+W> keyboard shortcut. 
If there have been modifications to the file since you last saved, ProFile will ask you if you want 
to save the file before you close it.  
 

To close all files in a particular family, select File > Close family. When you close all family files 
together, ProFile will open all the files together next time you select any family member file to 
open. If you close the files separately, family linking ends until you next open all the files together 
(so that they all appear in the ProFile Window menu at once).  
 
Both of these option close the file but leave the ProFile Forms window open. To exit ProFile 
altogether, select File > Exit or press <Alt+F4>.  
 

Print  
 
This section describes all you need to know to produce documents hard copy and PDF documents 
for your clients, including printing mailing labels and client letters.  
 

Print configuration  
 
With most Windows applications, when you send a file to the printer, you can choose how many 
copies you want to print. ProFile takes this copy feature one step further with customizable print 
jobs and sets.  
 
Printing is fully customizable with ProFile. Once you set up the rules for selecting forms and print 
jobs, ProFile handles the selection for you each time you print a client file or batch print a number 
of files.  
 
Read these instructions to learn how to customize your print configuration:  
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Print setup  
 
The printing functions in ProFile are extremely flexible. ProFile has several print options you can 
configure under File > Print setup.  
 

General options  
 
ProFile will automatically use the default Windows printer. Select ‘Always use Windows Default 
Printer’ to use the printer settings as defined by the Windows environment. However, you can 
select another printer if you prefer. Once you clear Always use Windows Default Printer click 
[Properties] to use the Windows Printer Setup dialog for your printer. 
  
You can select a different printer or tray for each category of form. Highlight a form category and 
set the configuration using the options (printer, tray, margins, etc.). Printing configuration is 
module-specific.  
 

How ProFile selects which forms to print  
 
By default, ProFile will automatically select the forms that need to print. To decide what to print 
from a particular file, ProFile follows simple rules. 
  

 Is the form used in the client file? ProFile only prints forms that contain data in the file.  

 Does the data in the file meet the job print condition? ProFile automatically selects one 

or more based on the condition for each Print job. For each possible print job, ProFile 

evaluates the condition that appears in the Select this print job when field (on the 

Options > Form selection dialog box). If the client file meets this job selection condition, 

ProFile will print the job. ProFile automatically selects multiple print jobs when the data 

in the client file meets the conditions for more than one print jobs. ProFile disregards the 

job selection condition if you override and select different jobs on the File > Print dialog 

box.  

 Which forms are included in the print job? Within each print job, ProFile checks to see 

which forms are included in the active print sets. If a particular form has no checkmark in 

any of the active set columns (on Options > Form Selection), ProFile will NEVER 

automatically select the form to print (even if it does contain data in the client file).  

 Are there manual overrides? ProFile looks for manual overrides to the selection on File > 

Print dialog box. You can make changes by selecting or clearing different checkboxes than 

you did on Options > Form selection. These changes apply to the current file only, but 

you can store them using the Keep selections option.  
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 Should the print set include a template? If the form is a customizable template form, 

ProFile compares client data to the Print condition for that form on Options > Templates 

before including a template in automatic form selection. A print condition of <1> will 

select the form for every client, and <0> ensures that template will never print.  

 

Customize form selection  
 
By default, ProFile will automatically select the forms that need to print. Use Options > Form 
Selection to define a different selection of forms for each Print job. Here is what you need to do 
to change the default print job for a ProFile module:  
 

1. Go to Options > Form Selection.  

2. Click on a module tab to customize the print jobs for that module.  

3. Choose one of the pre-defined print jobs from this drop-down list.  

4. Choose how many copies (sets) of your files you would like to print by selecting (making 

it black) or clearing (making the box white) the boxes next to the Print sets row. The print 

job can include up to five sets of forms.  

The rows at the top determine the format of the forms you include below. The modules 

have different features you can activate in the columns above the form list. The Print sets 

row selects the standard facsimile copies. Four per page reduces the size to save paper. 

For ProFile T2, you can create an RSI/Barcode form set. ProFile TP1 includes an alternate 

language option.  

Combine a selection in Print sets with a feature selection below, like 4 per page, Review 

marks, or for ProFile TP1, alternate language printing.  

5. Name your print sets in the top right-hand corner of the dialog box.  

 

 Hint: On File > Print > Print selection, you can set the option to Merge print 
sets. ProFile will then collate sets of the same name when you print multiple 
print jobs. For example, your CT23 print job may have a Client set, and your T2 
only print job can also have a set called Client. Select ‘Merge print jobs’ when 
you print both jobs in the same session. ProFile will print all the Client form 
copies together.  

 
6. Choose which forms you vary the form selection included with each set. For example, for 

ProFile T1 you may want to include the Keying Summary in the CRA set, but not in the set 

for your client or your office.  
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You can manually change the list by clicking on form copy boxes with the mouse. With 

your keyboard, highlight a form name and press numbers ‘1’ through ‘5’ to select/clear 

the form selection checkbox.  

If a particular form has no checkmark in any of the active set columns (on Options > Form 

Selection), ProFile will NEVER automatically select the form to print (even if it does 

contain data in the client file). For this reason, form selection for each print job should 

always reflect all the forms you would like to print if they are used in a client file.  

7. You can re-organize the print sequence for the listed forms. Depending on your 

preference, the form sequence may differ for each of the print jobs you use.  

8. ProFile will select a print job when a client data file meets the job condition. A condition 

is generally a comparison that uses a field code or alias to represent data from the client 

files.  

9. The form list includes all the forms available in the selected print job. In each of the active 

Print set columns, you can select or remove the forms to customize each set.  

10. Modify the print condition if you would like ProFile to select the print job based on 

different client data. For example, you can use a Client status variable in the condition. So 

you might customize ProFile to print the T1 Review copy print job when ClientStatus=‘In 

Preparer Review’. ProFile selects the print job for all clients when you enter <1> in the 

condition field. Enter <0> for a print job that you never use. (You can also use 1 and 0 on 

Options > Templates in the Print condition field.)  

 

 Make sure you understand how conditions work before you alter a default 
print job condition. Your change could cause ProFile to miss selecting a print job 
that is required for filing.  

 
On the File > Print dialog box you can override your usual form selection when a particular 

client file requires a different combination of forms. ProFile remembers these overrides 

if you choose the option ‘Keep selections’.  

 

Automatically print a template  
 
Each word processor template has a print condition that works with your Options > Form 
Selection settings to determine when ProFile will print that template. The default conditions that 
are set when you install ProFile will work correctly for any office. However, you may want to 
change these to suit particular business practices.  
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To change the Print condition for a template:  
 

1. Go to Options > Templates.  

2. Select a template from the list.  

3. In the Print Condition field, enter a condition to determine when to print the template:  

 Typically, print conditions include field codes and comparisons, like T1Info.B[8]=0.  

 Enter 1 in the Print condition field to print this template for every client.  

 Enter 0 to deactivate a template, if you do not want ProFile to print a template under 

any condition.  

4. Select your template for printing in one of the print jobs under Options > Form selection.  

 

Select a language for printing  
 
To provide for bilingual display and printing options, ProFile recognizes a default language, and 
an alternate language. If you have selected English (Canadian) as the regional language setting of 
your computer, English is your default language and the alternate language is French. If French 
(Canadian) is the selection in your regional settings, then English becomes the alternate language.  
 
The default language you set in Start > Control panel > Regional settings determines the default 
language for all your print jobs. You can choose the alternate language for one or more print sets 
on Options > Form selection or File > Print selection.  
 
Choose the alternate language on Options > Form selection if you usually run ProFile in one 
language, but print in the other (for one or more of your print sets). If you usually print in the 
same language as you run ProFile, leave the checkboxes in the language row blank.  
 

On Options > Form selection:  
 

1. Select the print job for which you need a print set in the alternate language.  
2. Activate the print set you want to use (select a checkbox in the row called ‘Print sets’).  
3. Select a checkbox in the language row to create a print set in the alternate language. 

Confirm that the forms included in the column below are the forms you want to print in 
that language.  

 

 In addition to data that you enter, forms also include information that you 
select from drop-down lists. These lists are translated throughout ProFile 
bilingual modules. When you print a form, ProFile will print these selections in 
the language of each print set (default or alternate).  
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File > Print > Print selection shows the automatic selection of forms for the current tax return 
file. Here you can change the print language of any form set for a particular client file.  
 
By default, ProFile will use your system language, or the language setting configured on Options 
> Form selection (if you have selected the alternate language). You can change the language 
selection for a particular client file on this dialog when you print the return.  
 
Although the default language for ProFile comes from regional settings, you can change your 
work environment to your alternate language using Options > Language. When you switch to the 
alternate language, your print sets will change at the same time (along with forms open in the 
Forms window). Since you are now working in your alternate language, you must select to print 
a set of forms in your default language.  
 

Print client files  
 
To print the current file open in the Forms window, select File > Print <Ctrl+P>.  
 

1. ProFile first checks to see if any audit messages are outstanding. ProFile will display audit 

messages to warn you of outstanding issues before you print. You can click [Cancel] and 

resolve the issues before you print OR click [OK] to print anyway.  

You can change the type of audit messages that will appear here when you begin to print 

a file that has outstanding issues. Select message types under Options > Environment > 

Audit > Prevent filing.  

2. In the Print dialog box, click the [Advanced] button to access advanced printing options. 

Click the [Advanced] button a second time to hide these options.  

3. For coupled or family returns, there will be two or more tabs at the top of the Print 

selection dialog box. Select which return(s) to print by putting an ‘X’ beside the name 

(Simplified Print selection dialog) or on the client tab (Advanced Print selection dialog). 

The list of forms can be different for each family member, so click on each tab to check 

the form selection. Automatic and manual form selection is separate for each family 

member.  

4. You can select from various print jobs, each with its own default form selections. Use the 

checkboxes to select any combination of print jobs to send to the printer. The highlighted 

print job determines which forms appear in the list below. You can customize a print job 

for a particular file you are printing (in other words, you can suppress forms selected by 

default, or add forms not ordinarily included).  

5. ProFile automatically selects forms to print, depending on your default settings for the 

print job (Options > Form selection) and which forms contain data in this particular client 
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file. Each column represents one set. You can print up to 5 sets of forms (copies for the 

client, your files, CRA, etc...).  

 Click the [Print Sets number] at the top of the column to activate a set. Click the 

corresponding set number in the 4 per page row if you want to print the set in 

reduced size for your files, or in the Review marks row to print these on the set. 

Depending on the ProFile module, you will see rows to configure sets for T2 RSI 

forms or TP1 alternate language printing.  

 To add other forms or suppress forms selected by default, click the numbered boxes 

beside the form names. Or, use the number keys 1 through 5 to add forms to sets. 

The form list displays forms from the highlighted print job (3). Right-click on the form 

list for ‘Clear all’ and ‘Select all’ options.  

 Select Options > Show only selected to display only the forms selected for printing.  

 Select ‘Keep selections’ if you would like to use your custom selection whenever you 

print this client’s file or include the file in a batch print. This does not affect the 

defaults you set for this print job on Options > Form selection, and will not apply to 

any other client file.  

6. If your printer does not have a duplex feature, use even and odd page selections to print 

on both sides of the page: 

a. Click the [down arrow] next to All pages. 

b. Select ‘Even pages’. 

c. When those pages finish printing, load them into the manual feed tray to print on 

the blank side.  

d. Select ‘Odd pages’.  

7. Select ‘Take snapshot’ to automatically take a snapshot  

8. Select Options > Date in heading to include the current date in the header for all forms 

in the selected print job(s).  

9. Select Options > Default printer to direct all your ProFile printing to the default Windows 

printer and the same paper source. This will save time when you load ProFile. To modify 

printer settings, turn this option off and select ‘Print Setup’ from the menu.  

10. Select Options > Merge print sets to merge and collate multiple print jobs. ProFile will 

only merge sets that have the same name on Options > Form selection.  

Use this feature when you are printing more than one print job at a time, and you would 

like to group sets of the same name. For example, you print a T2 federal return and an 

Alberta corporate tax return. If both print jobs include a set named Client, then Merge 

print sets will collate the jobs so that all the forms from the Client sets will print together.  
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Send multiple print jobs to the printer  
 
By default, ProFile will automatically select all the print jobs that apply to a particular client. On 
the File > Print dialog box, you can see which print jobs ProFile automatically selected and can 
change that selection.  
 
Select Options > Allow multiple jobs on the Print selection dialog to manually select multiple 
print jobs from the list of Print jobs. Clear the checkboxes for any jobs you do not want to print, 
and select any jobs you want to print for this client. If you clear the option, you can only select a 
single job from the Print job list. When you select a print job, ProFile automatically clears all the 
other print job checkboxes for you. Whether you use this feature or not, ProFile will always 
automatically select multiple print jobs for any client that meets the criteria for more than one 
print job (on Options > Form selection > Select this job when).  
 
For example, you may be printing a T2 client file for a company based in Ontario. Using the print 
job conditions from Options > Form selection, ProFile can select both the T2 print job, and the 
CT23 print job in one print session.  
Keep in mind that your print job selection, like your form selection, is separate for the client and 
spouse in ProFile T1 and T1/TP1. Using the defaults, ProFile automatically selects the correct set 
of forms for each spouse.  
 

Print slips or print preprinted forms 
 
For ProFile FX and ProFile T3, there are two extra functions under the File menu: Print Slips Setup 
and Print Slips.  
 
For certain slips and summaries, you can choose between printing on pre-printed CRA forms or 
printing laser facsimile copies on plain paper. Aligning data correctly on pre-printed forms will 
probably require a few tests, and some adjustments to the slip margins. Using the options on File 
> Slips print setup, you can customize the slip printing for your own printer(s), printer driver(s) 
and paper source(s) or trays.  
 

 Hint: You may need to adjust alignment slightly between different batches 
of the CRA pre-printed forms, if the margins are not identical.  

 
Slip printing options in ProFile also handle the summaries and forms that the CRA requires you 
to file with the slips. If you are using magnetic media to file slip data, you do not file paper slips 
or summaries but you must prepare a T619 (transmitter) form to accompany the diskette that 
you send. In addition, you must produce paper copies of the slips (for example, T4s) for the 
recipients. You probably also want a printed summary for your files (or for your client’s records).  
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Configure printing of slips and summaries  
 
When using ProFile FX, you’ll notice these functions under the File menu: File > Print Slips Setup 
and File > Print Slips. ProFile allows you to print slips as laser facsimiles or on pre-printed forms. 
If you are printing onto CRA pre-printed forms, you will need to complete a few tests to customize 
the slip printing for your own printer(s), printer driver(s) and work style.  
 

 Hint: With ProFile FX/Q you can submit slips and relevés to CRA and MRQ 
using electronic media filing. If you prefer, you can print the slips on pre-printed 
CRA laser forms. ProFile FX does not support dot matrix self-mailers.  

 
Slip printing is not just about slips but is also about handling those summaries and forms that go 
hand in hand with the slips (to meet CRA requirements). For instance, when doing magnetic 
media filing you do not file paper slips or summaries with CRA, but you do have to prepare a T619 
(transmitter) form to accompany the diskette that you send. In addition, you must prepare paper 
slips (for example, T4s) for the recipients. You’ll probably also want a printed summary for your 
records (or your client’s records).  
 

 
 

1. Print set - You have two choices for the sets of forms you produce: Paper Filing (includes 

a full set of slips and summaries required for submission) and Magnetic Media (that prints 

a reduced set of slips and summaries to complement your electronic submission).  

2. Always use Default Windows Printer - Select this option if you will print all your slips and 

summaries to the same bin on a single printer, using the default page margins. Clear this 

checkbox to customize printing of each copy. 
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3. Slip tabs - You can customize the printing options for each slip type and each copy 

independently.  

4. Slip sorting - set a default sorting method for your printed slips. You will see the slips 

organized according to your slip sorting selection when you open the File > Print slips 

dialog box.  

5. Group by slip copy - By default, ProFile will print a full slip set for the first individual before 

beginning the next. Select this checkbox if you would like to group your output by copy 

rather than by individual slip recipient. For example, with T4s this would mean that all 

Copy 1s (2 individuals per page) would print first, then all Copy 2/3s (2 slips for the same 

individual and notes on each page), then all Copy 4s (3 individuals per page).  

6. The slip/form list - Select checkboxes to indicate whether you want each slip/form to be 

selected to print by default in the Slip Printing dialog box. Highlight a slip/form to change 

the settings described in steps (7) through (13). 

7. Form type - ProFile can print slip data on pre-printed CRA forms, or in laser facsimiles. 

Depending on which item you select in the slip/form list, you may be able to choose 

between pre-printed and laser facsimiles. Some forms default to pre-print when CRA 

requires filing on a pre-printed form. The laser facsimile option is then no longer available. 

8. Printer and bin and properties - Clear the option, Always use Default Windows Printer 

(2), to change these settings. If you will use multiple printers or different bins on the same 

printer, select each slip or form in the list and choose which printer and/or bin you’ll use 

for that slip. For example, you may print all of your laser facsimile Copies 2-4 from printer 

tray 1, pre-printed Copy 1 from tray 2 and pre-printed summary forms from the manual 

feeder.  

 

 Hint: If a form splits across two pages, try INCREASING the left/right 
margins. With a LARGER margin, ProFile scales the entire form, which has the 
effect of shortening the length to fit on a single page.  

 
9. Margins/Offset - If the copy you have highlighted in the list is a laser facsimile copy, you 

can change all the margins and choose page position options. If you are working on a pre-

printed copy, there are fewer options. Intuit has designed the pre-printed type to fit 

precisely in the pre-printed form boxes. However, depending on your printer type and bin 

selection, you may need to adjust the left and top margins to line up the pre-printed 

forms. Use the [Test] button on the Print Slips Setup dialog to try the default settings, and 

adjust as necessary. 
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 Hint: If a form splits across two pages, try INCREASING the left/right 
margins. With a LARGER margin, ProFile scales the entire form, which has the 
effect of shortening the length to fit on a single page.  

 
10. Center horizontally - Select this option to centre a laser facsimile form on a page.  

11. Size to fit page - This stretches or shrinks a laser facsimile form to use the entire page 

(excluding margins). This option may have a different effect depending on your printer 

type. 

12. Pause for form change - This option is handy for a preparer who has only one or two 

printer bins available. During the printing process, ProFile displays a message instructing 

the user which slip copy or form will print next. You can set this pause for all your copies, 

or only for those copies that require a change from the regular paper supply. If you are 

printing more than a few slips, select the ‘Group by copy option’ when you use this 

feature. You’ll then have only one message appear to advise you when ProFile is beginning 

to print the next group (for example, all the Copy 1s). If you configure the Pause for your 

T4 CRA Summary (pre-printed), ProFile will display a prompt when it is time to load a pre-

printed Summary form into the bin or manual feeder. 

13. PCL Graphics Passthrough - If you find printing slow on your older model printer, try this 

option. As with other settings, you will need to select this option separately for each copy 

or form in the list. 

14. [Test] button - use the test button to help you configure margins on pre-printed slips and 

laser facsimile copies. Fine-tune the margin settings for a particular slip or summary, then 

press [Test] to print some sample data and check the alignment, particularly within the 

fields on pre-printed forms.  

 
 

Printing slips and summaries  
 
To print slips, you need to access the Print slips dialog box. Choose ‘Print slips’ from the File 
menu. Alternately, right-click on a slip, a detail worksheet or a summary in the Forms window. 
Select ‘Print’ from the context-sensitive menu. This example shows the T5 slip. 
 



Chapter 6  Learning About Taxes with Intuit ProFile: 2016 TY 

69 

 

  
 

1. Print Set - You can override your default Print set selection on this dialog box. The default 

depends on what you selected on Print Slips Setup.  

2. Slip Type - Select the type of slips you are preparing.  

3. Sort By - You can override your default Sort selection on this dialog box. The default 

depends on what you selected on Print Slips Setup. The sort feature only affects the 

sequence of your printer output. Slips within the file will appear in whatever order you 

entered them or sorted by Name/SIN using the Slips Sidebar.  

4. List of recipients - Select/clear the individual slips by clicking the checkboxes beside the 

names. With your keyboard, use the arrow keys to move the highlight bar and select or 

clear names with the <Spacebar>. Use the buttons [Select all] or [Clear all] to speed up 

your print slip selection.  

5. Slip state filter - A checkbox on each ProFile slip detail (for example, T5Detail) indicates 

whether or not the slip is amended. When it comes time to print slips, you can display 

original slips, amended slips or both in the list of recipients.  

6. Copies/Forms To Print - For this printing session, select which copies or summaries you 

will print. You group the output by individual (default) or by Slip Copy. To change the 

grouping, go to File > Print Slips Setup. On the setup dialog you can also request a prompt, 

for example to change paper between copies.  

 

Print a single form  
 
There are a number of ways to print a single form:  
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 Select Form > Print from the menu (this prints the form currently active in the Forms 

window)  

 Right-click on the form in the Forms window and select ‘Print’ from the context-sensitive 

menu  

 Open the form in the Forms window and click the Single Print Icon on the Shortcuts 

toolbar  

 Highlight a form name in the Form Explorer and click the [Print] button  

 

Print multiple forms  
 
There may be times when you need to print several forms but not a whole tax file. To do this, 
open the Form Explorer and follow these instructions:  
 

1. Using the keyboard, you can enter several form names into the ‘Form’ field by separating 

them with semi-colons. For example, T3;T4OAS;T4AP;T5.  

2. To select multiple forms using your mouse, press and hold the <Ctrl> key while you click 

the form names.  

3. To select a range of forms, click to select the first form in the range. Then, press and hold 

the <Shift> key while you click the last form in the range.  

4. When you have selected all the forms you want to print, click the [Print] button.  

 

Watermarks and stamps  
 
The ProFile Suite uses several different watermarks on the forms.  
 

Draft  
Forms that print with the Draft watermark are ones that still require changes from Intuit`s 
development team, and may include calculations Intuit has not yet updated to reflect the most 
recent budget(s). Intuit has included these forms in draft versions to help you plan with your 
clients, since changes to rates are often minor from one year to the next. You can enter data on 
Draft forms. When you install a ProFile update that includes a final version of the form, Intuit will 
correctly handle all data entered, or attach audit warnings to any amounts that you will need to 
review. 
  

Trial 
You will see the Trial watermark on the forms of any ProFile module for which you have only a 
trial license.  
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Do not file  
This stamp appears on the CRA or provincial ministry schedules included in a PDF eReview file. 
Sending a print job to a PDF file, rather than a printer, lets you create a standard-format electronic 
file that you can email to a client for review. The stamp ensures that a client does not print and 
submit the forms in error.  
 

PDF 
 
A PDF copy is an electronic version of your client file that you can email to a client for review 
purposes. It is a standard file format that your clients can read if they install the free program, 
Adobe Acrobat Reader™. File > Print/Email PDF will email to a client, with a PDF copy of the 
client’s tax return attached – all from within ProFile.  
 

Set up a PDF print set 
 
The PDF print process is similar to the ProFile print process, except that instead of printing a 
return, ProFile creates a PDF file and sends the files to the specified email address. Configure a 
print set to automatically produce a PDF when you EFILE a return:  
 

1. Select Options > Form Selection. ProFile comes configured with three print sets. This leaves you 

with two others to configure as you want.  

2. On the T1 tab, select the T1 EFILE print job.  

3. At the top right of the dialog box, enter PDF as the name for the fourth print set.  

4. At the top left of the dialog box, click on the box with a 4 in the Print sets row.  

5. Click on the box with a 4 in the PDF sets row.  

6. Choose what forms to include in the PDF by clicking the boxes in column 4.  

7. Click [OK] to save these options.  

 

Print and send a PDF file for eReview 
 
This function allows you to send email to your clients with a PDF copy of their tax return attached 
without ever exiting ProFile. A PDF copy is an electronic version of your client file that you can 
email to a client for review purposes. You cannot use a PDF to file an official return with CRA or 
the provincial ministries.  
 

 Hint: You must have a MAPI email client to use this function. Most email 
programs support MAPI. For example, MAPI has been supported since Outlook 
97 and Outlook Express 4.0. You and your client must have a PDF reader to view 
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and print the PDF files. Adobe Acrobat Reader is available for download from 
www.adobe.com.  

 
This PDF printing process is similar to the ProFile print process, except that instead of printing a 
return, ProFile creates a PDF file and sends the files to the email address you specify. ProFile 
automatically adds a watermark on each page in the PDF copy to ensure that this review copy is 
not suitable for filing. 
 
ProFile uses the same form selection criteria for PDF printing that it does for printing paper 
copies. ProFile will automatically include all the forms used in the client file, as long as the forms 
are selected on the Options > Form selection dialog box in the PDF print set. As with all print jobs, 
you can modify the form selection for a particular client at the time of PDF printing.  
 

Setting up passwords for PDF printing  
 
You can configure a password for the PDF documents that ProFile emails to clients. You can use 
a specific password that you create, or let ProFile automatically generate a password based on 
the Client’s information (such as their name and SIN number).  
 
To set up a password for emailed PDFs: 
 

1. Select Options > Environment. 

2. Click the [PDF] tab. 

3. In the PDF Security section, select a password that clients can use to read the PDF files 

they receive. With this password, clients can read and print the PDF, but can’t make 

changes to it. 

You can choose from the following items: 

 None: No password. 

 ClientName + SIN/BN/TAN (Smith333): The first 5 characters of the client’s last 

name or business’s legal name, followed by the last three digits of their SIN 

number (for individuals), Business Number (for T2 returns), or Trust account 

number (for T3 returns). 

 ClientName + DOB/Fiscal End date (SmithYYMM): The first 5 characters of the 

client’s last name or business’s legal name, followed by their date of birth (for 

individuals) or fiscal year end (for businesses and corporations) in YYMM format. 

 User Specified: A custom, static password that you create. 

When ProFile creates passwords based on a name, any spaces within the names are 

ignored. If the name has less than 5 characters, then all those characters are used. 
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4. In the Set Owner Password section, enter a password that allows changes to be made to 

the PDF file with tools like Adobe Acrobat™. 

 

 Tip: If you specify an Owner Password but set the User Password to ‘None’, 
clients are prevented only from making changes to the file. In this case, anyone 
can still read the PDF file with Acrobat Reader™.  

 
5. When you’re done, click [OK]. 

 

Sending a set of forms for eReview as PDF  
 
To print and email a PDF print set:  
 

1. Open a file and select File > Print/Email PDF.  

2. Select print set and forms to include in the PDF.  

3. Under Options, select a DPI (dots per inch) for the PDF. The smaller the DPI, the smaller 

the file. However, a smaller DPI can mean images and graphics are not as crisp. A higher 

resolution provides crisper printing but also increases the file size. 

4. Select Options > Delete PDF to erase the PDF after you send it.  

5. Click [Email template] and browse for a template. This is the text for the email message 

or ‘cover letter’ for the PDF file. You can create your own RTF template and then select 

Browse to link that template to the Email template menu. 

6. Enter the email address for your client.  

7. (Optional) Click [Preview] to preview the PDF file before sending.  

8. Click [Email] to create the email message (with the PDF attached). This launches your 

email program and creates a new message.  

9. Click [Send] on the message window to send the PDF. 

 

Indexes in PDF previews  
 
When printing or emailing previews of forms as a PDF, ProFile now generates a navigator index. 
When the PDF is opened, links to individual forms and sections are listed left side, allowing clients 
and other reviewers to quickly jump to the spot in which they’re interested. 
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EFILE  
 
Electronic filing includes options to submit tax data to the CRA (or to a provincial ministry) in an 
electronic format. Electronic filing is an alternative to filing printed (paper) returns with the 
government.  
 
ProFile automates most of the electronic filing process, and your steps are simple:  
 

 Make sure the return(s) or slips you wish to send are eligible for electronic or magnetic 

media filing.  

 Build transmission files. For batch transmissions, or some single return transmissions, you 

need to build a special file that contains data from the tax returns and slips processed 

with ProFile.  

 Connect to transmit your files. 

 Print EFILE reports.  

 
Depending on which materials you file electronically and what method you choose, you may need 
to set up an account with an internet service provider. Intuit Canada does not provide an internet 
connection or EFILE transmission services, so it’s up to you to choose the service provider you 
prefer.  
 

Restrictions 
 
Tax professionals considering electronic filing should be aware that some returns are not eligible 
for electronic filing. For example, when filing T1 returns, you cannot EFILE a non-resident return, 
a return reporting income from multiple jurisdictions, or a return for a previous year. 
 
For more details, see E-services for tax preparers on the CRA website. http://www.cra-arc.gc.ca  

  

http://www.cra-arc.gc.ca/
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Tax preparers who file more than 10 returns 
 
The CRA has recently introduced new mandatory Internet Filing requirements for certain tax 
preparers. Starting in January 2013, tax preparers who receive payment to prepare more than 10 
income tax returns in a year will be required to file them electronically. This applies to both T1 
individual income tax and benefit returns and T2 corporation income tax returns for 2012 and 
subsequent tax years.  
 

 Important: ProFile will not prevent you from printing more than 10 returns 
for filing on paper. However, if you do so, you might be liable for fines and other 
penalties from the CRA. 

 
For more details, contact the CRA, or see www.cra.gc.ca/mandatoryelectronicfiling 
 

Supported forms and slips 
 
You can electronically file data for the following forms, slips, and returns. 
 

 Electronic file types 

 T1 returns 

 TP1 returns (Quebec) 

 T3/TP-646 slips 

 FX/Q slips 

 T2 returns 

 

T1 returns 
 
All electronically filed T1 returns are submitted by Internet. There are two online systems 
available for T1 returns: EFILE On-Line and EFILE On-Line Plus. The EFILE On-Line system accepts 
a single return per transmission, and provides an immediate response, during the transmission 
session. EFILE On-Line Plus is a batch system, and there is an interval of days between 
transmitting files and receiving a response from the CRA system.  
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T1 EFILE On-Line  
 
EFILE On-Line and EFILE On-Line Plus differ from individual NetFile for taxpayers filing their own 
tax returns. The EFILE On-Line systems allow professional tax preparers to file tax returns over 
the Internet on behalf of their clients.  
 
Take a look at these topics to learn more about the EFILE On-Line process. 
 

Prepare to Internet file T1 returns  
 
If you plan to EFILE returns using the CRA EFILE On-Line Internet filing service for professional tax 
preparers, complete these steps:  
 

1. Complete an RC153 as a professional who files returns electronically on behalf of clients. 

The CRA will assign an EFILE On-Line number and password.  

 

 CRA does not permit NetFile on behalf of other taxpayers. To transmit for 
others you must have an EFILE transmitter number. You may NOT use the 
taxpayer’s WAC (web access code) to transmit on his/her behalf.  

 
2. If you don’t already have one, set up a dial-up or high-speed Internet account with an 

Internet Service Provider (ISP).  

3. Confirm that you have Microsoft® Internet Explorer 5.5 or greater, with Strong Encryption 

(128-bit), a requirement for secure data transmission using EFILE On-Line.  

4. Contact your local EFILE help desk to inform CRA representatives that you will be 

transmitting returns over the Internet.  

5. Acquire pre-printed copies of the T7DRA form so that taxpayers with a balance owing can 

make payments directly at the bank. ProFile formats client data to print directly on this 

form, but make sure you do a test-run in advance. Some configuration may be required, 

depending on your printer model.  

6. Set up the ProFile EFILE configuration under EFILE > Options. You can use the Wizard or 

follow the instructions in Configure T1 EFILE On-Line.  

 
You can now begin making client returns eligible for EFILE.  
 



Chapter 6  Learning About Taxes with Intuit ProFile: 2016 TY 

77 

 

Configure T1 EFILE On-Line  
 
Complete the following steps to configure ProFile to transmit tax returns over the Internet. 
Complete your electronic filing options (EFILE > Options) before you build your first EFILE On-Line 
transmission unit (*.TAX).  
 

1. Select ‘Options’ from the EFILE menu.  

2. In the left-hand pane, select ‘EFILE Internet’ and provide the following information:  

 

 Once you select ‘EFILE Internet’ under EFILE > Options, the [T1 Wizard] 
button is available. Click this button to complete step-by-step configuration for 
T1 EFILE.  

 

 EFILE On-Line Number and Password (from the CRA),  

 

 Note: The SEND and EFILE On-Line Plus options are set up automatically. 

 
3. Click [OK].  

 

Make client returns eligible for EFILE  
 
ProFile contains audit features to help prepare accurate EFILE returns:  
 

1. Under the Filing section of the Info form of a client file, select ‘Yes’ next to the question 

‘EFILE this return?’.  

When you configure your EFILE options (EFILE > Options), new T1 files that you create 

default to answer ‘Yes’ to the question, ‘EFILE this return?’. If you carry forward a file that 

was sent by EFILE last year, the question in this year’s return is also ‘Yes’ by default.  

2. Under Options > Environment > Audit, select the checkboxes to Remove Audit Messages 

on preparer and/or partner sign-off and select the preference to Display Review Marks.  

3. Use the review marks to sign-off on any diagnostics that appear in red in the Active 

Auditor. Alternately, right-click on the Auditor messages to sign-off without jumping to 

the form. T1 EFILE On-Line and EFILE On-Line Plus messages appear under the EFILE tab 

in the Active Auditor.  
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 Hint: Review your TP1 returns for EDI audit messages (using the EDI tab in 
the Active Auditor). ProFile automatically updates the TP1 status (File > 
Properties) to Eligible once you have addressed all audit messages.  

 
If you have any difficulties with this process, refer to the topic, Troubleshoot EFILE problems. 
Otherwise, you can simply wait until you receive acknowledgements for your file. A tax return 
file changes to eligible status as soon as you clear all EFILE diagnostic messages in the Active 
Auditor.  
 

Transmit T1 files via the Internet  
 
Follow this process to transmit a T1 EFILE On-Line file (*.TAX) via the Internet.  
 

1. Open the file you want to transmit.  

2. Select EFILE > EFILE this return or <Ctrl+F11>. 

3. If there are still unresolved EFILE errors in the client file, ProFile will display an error 

dialog. You will need to resolve these before you can transmit the return.  

4. ProFile automatically completes your submission through T1 EFILE On-Line.  

5. When a return is accepted, you will see a Confirmation number on the final page of the 

EFILE On-Line session. You can print a copy of this page for your files. ProFile automatically 

updates the EFILE status of the client file (on File > Properties), and transfers the 

Confirmation number to Part H on the T183.  

6. If the CRA system rejects the return, you will see this message on the final page of the 

EFILE On-Line session. ProFile automatically updates the client file with CRA EFILE error 

messages on the EFILE tab of the Active Auditor. You will need to resolve those errors 

before re-transmitting the file.  

 

Print EFILE Reports  
 
With ProFile, you can print full reports that follow the CRA guidelines. You can also print a quick 
report summary. ProFile will save session log reports only if you have chosen Retain EFILE log in 
your EFILE Options (EFILE > Options > T1 > EFILE Internet).  
 

1. Select EFILE > Reports to display the Report dialog box. All your EFILE reports are stored 

in the same folder, as defined under EFILE > Options > T1.  



Chapter 6  Learning About Taxes with Intuit ProFile: 2016 TY 

79 

 

2. Select from the drop-down list the type of report file you would like to view or print.  

 

 Hint: Refer to the table of EFILE file types for descriptions of all files related 
to electronic filing.  

 
3. Highlight a report in the file list. A summary of the report appears in the preview panel. 

To view a session log, highlight a file with the extension .SLG.  

4. Click [Open] to view the full EFILE report.  

5. Click [Print] to produce a hard copy of the report for your records. I recommend that you 

keep printed copies of all electronic filing reports.  

6. In the event that you see an unprocessed .ACK (.TAC or .EAC) file, this indicates that 

ProFile has not automatically changed the file extension to .ACX (.TXA or .EAX) to show 

processing is complete. You can open the file and click [Update].  

 
You can find the Techlog.txt file in your EFILE folder, but you need to browse for the file through 
Windows, not ProFile. You will only need to refer to the Techlog when troubleshooting, that is, 
when you are having difficulty connecting and transmitting to your service provider or to the CRA 
EFILE computers. 
 

Print session details 
 
If you have selected the EFILE > Options > T1 > EFILE Internet > Show Print Prompt at End of 
Session, you will be able to print the session file(s). Just select the checkboxes for the files you 
wish to print and click the [OK] button.  
 
If you decide not to print session details, turn off the option under EFILE > Options > T1 > EFILE 
Internet > Show Print Prompt at End of Session, or choose ‘Don’t show this box next time on the 
Print session details?’ dialog box.  
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Chapter 6 - What we learned 
 
You have finished Chapter 6. Congratulations! 
 
In this chapter we learned: 
 

 Navigate in ProFile 

 Work in Profile 
 
If there are any details that you would like to review, please go through the chapter again. 
 
 


