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Chapter 8 – Exploring ProFile cont’d 
 

Topics 
 

 Introduction 

 Getting Started 

 Client Explorer 

 HyperDocs 

 ProFile Connect 

 Continue to learn 

 What we learned  

 Classroom Review (Quiz) 
  

Introduction to Chapter 8 

Estimated time 
 
About 30 min 
 
In this chapter, we will: 
 

 Manage ProFile 

 Continue to Learn with ProFile 
 
Let’s get started! 
 

Getting Started 
 
ProFile T1 software is reliable, easy-to-use and offers sophisticated features that will make the 
tax season more productive for even the experienced T1 tax professional. ProFile T1 can capture 
the data from past year returns created using certain competitors’ software. Whether you carry 
forward individual client files, or carry files forward in batches, you will find the process quick 
and convenient.  
 
Using ProFile`s WYSIWYG (what you see is what you get) forms, you can view and edit federal T1 
and Québec TP1 forms in French or English. When it comes time to print a return, you can print 
the forms in either language or both, at the click of a button.  
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Manage 
 
ProFile includes sophisticated tools to help you manage your client files. 
 
This section will cover the following sections of: 
 

 Client Explorer 

 HyperDocs 

 ProFile Connect 

 Continue to Learn 
  

Client Explorer 
 
The Client Explorer is ProFile’s advanced client and file-management tool. The Client Explorer is 
only available to those clients with a Premier licence.  
 
The first time you save a new client file, ProFile adds a record for that client to the database. 
Whenever you save a client file, ProFile automatically updates the record for that client.  
 
You can choose to use standard Windows file dialog boxes (under the File menu) or the Client 
Explorer for your file-management. I recommend that you use the Client Explorer since it offers 
many time-saving features. The Client Explorer does not contain the extensive data found in each 
individual client file. Instead, it contains references to the file location. However, by using the 
database features, you can print reports and export files that include any data from your client 
files. Also, the Client Explorer is required for to batch print and batch EFILE returns.  
 

Advantages to using the Client Explorer  
 

The Client Explorer is the advanced ProFile client and file-management tool, available to clients 
with a Premier licence. Some of the benefits of the Client Explorer are:  
 

 Faster network access – The Client Explorer will provide faster access for those in larger 

offices who share a database over the network. The ProFile database uses technology 

that is efficient on standalone workstations or small networks.  

 A client-centred view – Now, you can view all the files for a each client in one place. The 

Client Explorer groups files in a single client record, regardless of the type or year of the 

file.  



Chapter 8  Learning About Taxes with Intuit ProFile: 2016 TY 

5 

 

 Customized views – Customize the display criteria for your client files and save those 

customizations. Use filters to quickly and easily change how you view your files and which 

files you view.  

 Intuitive batch functionality – The Client Explorer batch functions work the same way 

Windows works. Use the filters to view only the files you need, select all and then select 

a function from the Client menu or the right-click, context-sensitive menu.  

 Access to client details – Use the Client Explorer as your address book as well as a file-

management tool. Addresses display on screen you can change a client’s address in the 

Client Explorer without affecting previously filed returns. Customize the Details pane to 

include any fields from client returns.  

 
And, these benefits are only the beginning. This new database structure allows Intuit to expand 
what ProFile can offer. In the future, ProFile will link out to other files related to the client. For 
example, you could add a letter you sent to the client to the list of files and launch that document 
from ProFile. Or, how about sending broadcast emails to your clients straight from ProFile. Stay 
tuned over the next year for more improvements.  
 

Client Explorer setup 
 
When you launch ProFile the first time after you install the program, you will see the Client 
Explorer Setup Wizard that will help you to link the Client Explorer to another database on the 
network, set up a standalone database on your machine, or/and share your locally-stored 
database to others on the network. Follow the steps as they appear on screen, to:  
 
You can always return to the Client Explorer Setup Wizard by clicking the Setup Wizard button 
on Options > Database. You can always change your option to share or link databases over the 
network by changing your settings under Options > Database. 
 

Create a standalone Client Explorer  
 
If you choose not link to another Client Explorer on the network or share your database with 
others, ProFile automatically creates a standalone database on your machine. No one else will 
be able to access this database over the network unless you share it later. 
 

Link to a shared Client Explorer  
 
The first time you open ProFile, the Client Explorer Configuration Wizard searches for other 
machines on your network that are sharing a Client Explorer database. If it finds a Client Explorer 

file:///C:/Users/Michael/AppData/Local/Temp/hcclientexplorer.htm
file:///C:/Users/Michael/AppData/Local/Temp/hcclientexplorer.htm
file:///C:/Users/Michael/AppData/Local/Temp/hcclientexplorer.htm
file:///C:/Users/Michael/AppData/Local/Temp/hcclientexplorerwizard.htm
file:///C:/Users/Michael/AppData/Local/Temp/hcclientexplorer.htm
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sharing its database on another machine, you can choose to link your Client Explorer to this 
database or configure your machine as a standalone database. 
  
Once you share the Client Explorer on the network, you can point other computers to that shared 
database: 
  

1. Launch ProFile.  

2. Go to Options > Database. 

3. Select ‘Use Client Explorer’.  

4. Select ‘Shared Server’. ProFile will search for databases shared on the network.  

5. Select a ‘ProFile Server’ from the drop-down list.  

6. Highlight the database on that server that you wish to use.  

7. Click [OK]. When you launch the Client Explorer, you will see the client list stored in the 

ProFile Server.  

 

Share your Client Explorer with others  
 
If you do not link to another database on the network (you chose ‘No’ in the first Wizard step, 
you can choose to have others link into the database you will create on the machine. The wizard 
will ask you to provide a name for the database that others will see over the network. 
  

 Note: If you want to share databases from more than one computer on the 
same network, or if you want to install a shared database on a server, you must 
first install ProFile on the computer(s) that will share a database.  

 

Open the Client Explorer 
 
To access the Client Explorer, select Goto > Client Explorer, click the toolbar icon or press <F3> 
on the keyboard.  
 
You do not have to close the Client Explorer window to return to your ProFile client files. It can 
remain open as you work. If the Client Explorer is already open, you can switch to it from a client 
file by selecting Window > Client Explorer.  
 
 
 

file:///C:/Users/Michael/AppData/Local/Temp/clientexplorer_share.htm
file:///C:/Users/Michael/AppData/Local/Temp/hcclientexplorerwizard.htm
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Create an index in the Client Explorer 
 
ProFile only adds a file to the list of Clients when you create or open a file and then save it, so 
when you first open the Client Explorer, you will not see any client names or files listed. If you 
have existing ProFile or competitor files, you must have ProFile scan your hard drive and create 
an index of them in the Client Explorer.  
 
To create an index of your files:  
 

1. Click the [Index] button in the top right-hand corner of the Client Explorer window.  

2. [Browse] to the folder where you keep your files.  

If you cannot remember where your files are, you can index the entire hard drive. Just 

enter C:\ in the File Folder field.  

 

 Hint: You cannot index your files in the Client Explorer using mapped 
network drives (for example, U:\c\data). You must browse to the computer via 
the Network Neighborhood to use UNC file names (for example, \\picasso\data)  

 
If your files are in more than one folder, browse to the folder that contains all these 

subfolders and select the ‘Include subfolders?’  

3. Choose how to treat password-protected files. Select:  

Skip password protected files to ignore password-protected files when creating an index. 

Password-protected client files will not appear in the client list.  

Prompt for passwords to enter the password for each password-protected file as it is 

included in the database. Use this option if you use more than one password for your files  

Use this password and enter a password to use for all password-protected files as they 

are included in the database. Use this option if you use the same password for all your 

files.  

Select ‘Ignore clients with no unique ID’ (i.e. SIN, BN) to automatically include clients with 

the same Social Insurance Number or Business Number in the Client Explorer, rather than 

choose which client to associate the files to.  

4. If you only want to find files for certain taxation years or certain types of returns or if you 

want to choose which competitor files are indexed, select ‘Select File Types’. This expands 

the dialog box to allow you to include or exclude certain file types in the index.  

Use the tabs (T1, T2, T3, FX, etc.) to view the list of files to index for each module. Then, 

select or deselect the options on each tab. By default, the Client Explorer indexes all 

ProFile files and any competitor files from the previous taxation year.  
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5. Click [OK] to begin indexing your files. A status box will appear on the screen showing you 

the progress of the indexing. You can cancel the indexing process at any time by clicking 

the [Cancel] button.  

6. If you have multiple files with the similar identifying data (such as the same SIN number), 

you may be asked to choose a client to associate the files to. For example, this could occur 

if you have two copies a client file saved in two different locations of your hard drive.  

If this occurs, the Select ‘Client’ dialog box will prompt you to select the appropriate client 

from the list and click [OK]. If you do not want to associate these files with a particular 

client, click [Skip] to continue indexing. These files are as separate clients in the Client 

Explorer.  

7. Once ProFile finishes creating the index, the status dialog box will disappear and you will 

see client names on the tab of the Client Explorer.  

 

Add files to the Client Explorer 
 
There may be times when you would like to move files from a CD, a network hard drive or a local 
folder into your default folder for client files and into the index. For example, you may be using 
a CD to transfer a client file from a laptop that is not on your network.  
 

1. Open the Client Explorer <F3>.  

2. If the files are stored on a CD, insert it in your CD drive. Select Client > Add files to Client 

Explorer.  

3. If you have several ProFile modules, click the tab for the module that matches the files 

you want to add.  

4. Using the drop-down list for the ‘Look in’ field, browse to locate the files you would like 

to add to the index. You can browse to a CD, a local folder or a network drive.  

5. Select a file or use <Ctrl+Left click> to select several files.  

6. Click [Add]. ProFile copies these files into the default folder specified under Options > 

Environment > Files and updates the index to include the new files.  

 

Search the client list in the Client Explorer  
 
At the top of the Client Explorer, you can search for files containing specific identifying 
information.  
 



Chapter 8  Learning About Taxes with Intuit ProFile: 2016 TY 

9 

 

 
 

1. The drop-down list on the left shows the types of information you can use in a search. 

The options available in the drop-down list depend on the module filter tabs selected. For 

example, if you only check the box on the T1 module tab, you will not have the option to 

search by Business Number or Trust Number.  

2. Enter the data you want the Client Explorer to use in the search:  

 To search based on the Client name, type the client’s last name. If you also know the 

client’s first name, type the last name, a comma and then the first name. For 

example, to search for Georges Beauchamp, enter: Beauchamp, Georges. You can 

also enter just the first few letters of either the first or the last name.  

 To search based on the SIN, Business Number, Trust Number or Client Reference 

Number, enter the number you are looking for. If you do not know the entire 

number, enter just the first few digits and the Client Explorer will provide you with 

a list of possible matches.  

 

 Hint: To set a Client Reference Number for a client, right-click on the client 
record within the Client Explorer and select ‘Edit Client Details’. Then, enter the 
number at the top of the dialog box.  

 
3. Click [Search] to narrow the list of files in the client list to those that match the criteria 

you set.  

4. Click [Clear] to clear the search and to once again view all the files in the view.  

 

Work with files in the Client Explorer 
 
Once you have a list of files in the Client Explorer, there are many actions you can initiate from 
the Client Explorer.  
 
Click on a file with the right mouse button to see a list of the available functions for that file. You 
can also select a file and choose these options from the Client menu:  
 



Chapter 8  Learning About Taxes with Intuit ProFile: 2016 TY 

10 

 

 Open Files – Opens the file within ProFile. To open multiple files at once, hold down the 

<Ctrl> key and select two or more files and then choose this option.  

 Carry Forward Files – Carries forward a file within ProFile. This option is only available on 

files that ProFile can carry forward. To carry forward multiple files at once, hold down the 

<Ctrl> key and select two or more files and then choose this option.  

 Build EFILE file – Builds an EFILE file for Internet or disk filing. To build multiple files at 

once, hold down the <Ctrl> key and select two or more files and then choose this option.  

 Edit Client Details – Opens a dialog where you can edit the details for a particular client 

without opening the files.  

 Print Files – Prints the selected file or files.  

 Print Selected Forms in Files – Opens a dialog box where you enter the name of the forms 

form(s) you want to print from the selected file or files.  

 Print Slips in Files – Opens a dialog box where you choose which slips(s) you want to print 

from the selected file or files.  

 Print Mailing Labels – Prints mailing labels for the selected files.  

Export – Opens a dialog box that allows you to choose which data to export to a text file.  

 Print Report – Opens a dialog box that allows you to choose which data you want to print 

in a report. 

 Move Files – Moves file(s) to another location. The advantage to using this feature rather 

than similar file operations provided by Windows is that ProFile will properly maintain the 

database list so that you do not have to re-index it.  

 Copy Files – Creates a copy of the file at a new location. Use this function to back up files 

onto a disk or a different drive.  

 Delete Selected Items – Deletes the selected file(s) from the index and your hard drive. 

To delete for multiple files at once, hold down the <Ctrl> key and select two or more files 

and then choose this option.  

 Clear All – Deselects all the files on the tab currently displayed in the client list.  

 Select All – Selects all the files and clients on the tab currently displayed in the client list.   
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HyperDocs 
 
The HyperDocs feature allows you to attach multiple documents in any format to a form or field 
in your client return.  
 

Link documents to your tax returns via HyperDocs 
 
To add a new document: 
 

1. Open the HyperDocs window (File > HyperDocs) and click [Add] or press <Ctrl+D> to 

browse to the document you wish to add. 

To attach a HyperDoc to a specific field on a client form, right-click on the field and select 

‘Attach HyperDoc’.  

2. Choose whether to ‘embed’ or ‘link’ your document. 

o Embedded documents open as read-only and cannot be edited in ProFile. 

o Linked documents open from the source, so you can edit them directly in ProFile, 

and your changes will be saved to the source document on your computer. 

 
To detach a document from a specific field, right click the field and select ‘Detach HyperDoc’. The 
document will still be attached to the form, but will no longer be linked to a specific field.  
 
To remove a HyperDoc document, right-click on the document in the HyperDocs window and 
choose ‘Remove’, or select the document and press <Ctrl+R>. 
 
If you delete a form that had HyperDocs attached to it, the HyperDoc will also be deleted. 
Deleting a HyperDoc will only remove the link or embedded document from ProFile - it will not 
affect the source file stored on your computer. 
 

 Note: HyperDocs and associated comments will be stored with your files, 
but will not be included with T1 EFILE or TP1 NETFILE transmissions. 

 

Managing attached documents via HyperDocs 
 
The HyperDocs feature allows you to attach multiple documents in any format to a form or field 
in your client return.  
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From the HyperDocs window (File > HyperDocs), you can you can add, remove and manage your 
attached documents, including those attached to a specific field. 
 

Attach documents 
 
To attach a new document: 
 

1. Open the HyperDocs window (File > HyperDocs) and click [Add] or press <Ctrl+D> to 

browse to the document you wish to add. 

2. To attach a HyperDoc to a specific field on a client form, right-click on the field and select 

‘Attach HyperDoc’.  

3. Choose whether to ‘embed’ or ‘link’ your document. 

 Embedded documents open as read-only and cannot be edited in ProFile. 

 Linked documents open from the source, so you can edit them directly in ProFile, 

and your changes will be saved to the source document on your computer. 

 

 Note: For CO-17 electronic submissions, you can only include one 
document per submission in .PDF, .JPG or .GIF format. 

 

Add comments to an attached document 
 
To add notes or reminders for your own use, select an attachment and enter your information 
under Comments (for your reference). 
 
Comments will not be submitted to the CRA or Revenu Québec with your electronic return. 
 

Open attached documents 
 
From the HyperDocs window, double click on the document, or select it and press <Ctrl+O>. 
If the document is linked, ProFile opens it from its source and saves any changes you make 
directly to the source file stored on your computer. If the document is embedded, ProFile opens 
a read-only version. 
 
You can keep HyperDoc documents open while you continue working in ProFile. 
 



Chapter 8  Learning About Taxes with Intuit ProFile: 2016 TY 

13 

 

 Hint: If you have two computer monitors, display ProFile on one screen and 
your document on the other for easy reference. 

Synchronize out-of-date documents 
 
If you alter your source document outside of ProFile after attaching it to a return, you will need 
to synchronize the document to apply your changes. 
 

Detach or remove documents 
 
To detach a document from a specific field, right click the field and select ‘Detach HyperDoc’. The 
document will still be attached to the form, but will no longer be linked to a specific field.  
 
To remove a HyperDoc document, right-click on the document in the HyperDocs window and 
choose ‘Remove’, or select the document and press <Ctrl+R>. 
 
Each time you attach or remove a document from a client return, ProFile creates an entry in the 
File > Properties window to help you keep track of the client history. 
 

Delete forms with attached documents  
 
If you delete a form that had documents attached to it, the HyperDoc document will also be 
deleted. Deleting a HyperDoc document will only remove the link or embedded document from 
ProFile - it will not affect the source file stored on your computer. 
 

 Hint: The right-click menu in the HyperDocs window includes additional 
options to help you manage your documents, such as the option to choose 
between the ‘Icon’ or ‘Details’ view. 

 

Synchronizing out-of-date documents via HyperDocs 
 
If you alter an attached document outside of ProFile, you will need to synchronize the document 
to apply your changes. 
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 Note: Embedded documents open as read-only. To make changes, you 
must edit the source file and synchronize it in ProFile. You can edit linked 
documents directly in ProFile, as they open from the source and your changes 
are saved to the source file. 

 
Out of date documents are displayed in red in the HyperDocs window, with an exclamation point 
icon. In Details view, there is also a column to indicate whether a file is out of date. 
 
To synchronize an out of date file, right click the document and select ‘Synchronize’. 
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Continue to Learn 
 
This section will cover the following sections of: 
 

 In-product help 

 Training and tutorials 

 Online resources 

 Live Community 
 

In-product Help  
 
The full help system, the ProFile in-product help, includes program help, task-related ‘How to’ 
help and form help. It is your launching point for all sorts of useful resources. Both the program 
help and the form help are context-sensitive. If you want to browse the help topics, choose 
‘ProFile Help’ from the Help menu.  
 

Opening the ProFile In-product Help 
 
You can display help in a number of ways and from virtually any place in the software:  
 

 Press <F1> at any time.  

 Select Help > ProFile Help from the main menu to browse through all the help topics.  

 Click the [Help] button that appears on most ProFile dialog boxes. This displays general 

help about the dialog box.  

 
Select a module from the drop down list to view that module’s help.  

 The [Help] button links you to help topics on forms, how-to topics for completing tasks 

and news about what’s new in the module.  

 The [Web Site] button links you to Intuit`s web site where you can download updates, 

participate in the discussion forum and access up-to-the-minute news on Intuit Canada 

happenings.  

 The [Online Resources] button gives you access to frequently asked questions and lets 

you search Intuit`s web InfoBase.  

 The [Contacts] button links you to a web page with links to government contact 

information.  

 

Help contents  
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The Contents tree view appears on the left side of the help dialog box. Help is organized by topic. 
A book can hold any number of related help topics, including other help books.  
 
Click a Book icon to open a book. Then, click any Help topic icon to display the help topic in the 
right side of the help window. This hierarchical organization of the extensive help system means 
that you can quickly focus on those help topics that interest you.  
 

Help index  
 
There is an index that you can use to search the help system for a particular word. On the left 
side of the Help Dock, click the [Index] tab. Then, type a keyword. ProFile will find your keyword 
in the index. Double click the word to display a list of topics that share this index reference.  
 
For the most comprehensive index search, first select from the drop-down list of modules. The 
software will search both the module AND program help file for your index term. 
 

Interface help  
 
You can right click your mouse in any dialog box field and select ‘Help’. 
Or press <F1>.  
 

Training and tutorials  
 
ProFile in-product tutorials provide step-by-step, interactive lessons on how to use the software. 
The tutorials present the essential ProFile features and teach you how to enter data.  
 
Before you begin working on client files, I recommend you complete at least the ‘Getting Started’ 
tutorial. This tutorial introduces you to ProFile and helps you create your first file. Complete the 
other tutorials when you want more details on specific ProFile features. 
 

To start a tutorial: 
 

 Go to the Training menu, point to the module you’d like to learn about, and select the 

desired tutorial. 

The tutorials appear at the top of the ProFile window. Follow the instructions as they 

appear. 
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To navigate through a tutorial: 
 

 To move to the next screen in a tutorial, click the [Next] button. 

 To move to the previous screen in a tutorial, click the [Previous] button. 

 To end a tutorial and return to ProFile, click [Cancel]. You can end a tutorial at any time. 

 

Want more training? 
 
Additional training options are available from the Intuit website. Register for seminars and 
webinars from Intuit-approved sources, view how-to videos from ProFile staff members, and take 
advantage of Intuit`s free online self-paced training. 
 
For more details, go to the Training menu and click [Other Training Options]. Or, visit the ProFile 
Training website directly at http://profile.intuit.ca/professional-tax-software/training.jsp 
 

Online resources  
 
Intuit publishes information on Intuit`s website, in emails to their client base, and in ProFile`s in-
product help system. You can access most online resources directly from ProFile: 
 

 To view the latest information about the current release (including News/Alert articles, 

What’s New articles, and Known Issues), go to the Online menu, point to Update 

Information, and select the type of information you want. 

 To visit the Live Community and share tips with other users, go to the Online menu and 

select ‘Live Community’. 

 To visit the ProFile Training website for seminars, webinars, and free self-paced training, 

go to the Training menu and select ‘Other Training Options’. 

 To visit the ProFile product website for purchase and other information, go to the Online 

menu and select ‘Intuit Canada Website’. 

  

http://profile.intuit.ca/professional-tax-software/training.jsp


Chapter 8  Learning About Taxes with Intuit ProFile: 2016 TY 

18 

 

Live Community 
 
The ProFile Live Community feature lets you interact with other tax experts and ProFile users, in 
real time. 
 

 
 
Use the Live Community to ask a question, view answers to questions on tax topics that interest 
you, and share your knowledge by answering questions from other users. 
 
In order to ask or answer a question, you will first need to create a user account so you can set 
up a screen name. You will be prompted to create one the first time you ask or answer a question. 
 

To ask a question 
Type your question above the [ASK] button. When you are finished, click [ASK].  
 

To see what others are asking 
 

 Click on one of the questions in the Relevant Q&A section. Click [See more] to review the 

entire list of questions. 

Or,  

 if you created an account, go to your Q&A page and enter a topic in the Search field. 

 

To answer a question 
Click on the question you wish to answer and then click [Submit An Answer]. 
 

Sign in to your Live Community account 
 
You will be prompted to create your user account the first time you ask or answer a question. 
  
After your initial signup, your screen name will automatically display under the Live Community 
heading. Click on the drop down arrow next to your name and select ‘My Q&A’.  
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From there, you will have access to a list of questions you have asked and answers you’ve 
submitted.  
 
Furthermore, by clicking Edit My Profile, you can upload a photo, enter your contact information, 
information about your business, and other fun facts about you! (Of course, you’re not required 
to do so, if you prefer not to.) 
 

To turn Live Community on or off 
 
By default, Live Community will display every time you open ProFile. The window will remain 
open throughout your session; it will stay visible as you change forms, and even when you switch 
between modules! The window can be moved, resized or minimized to your liking. 
 
If you prefer not to display Live Community, you may close the window at any time by clicking 
the ‘X’ in the top right corner; however, doing so will only turn off the feature for the current 
session. To prevent Live Community from displaying every time you open ProFile, go to Options 
> Environment > System and remove the checkmark from the ‘Show on startup’ option that 
appears under the ‘Live Community’ section.  
 
To launch the feature again once you have closed the window, select Online > Live Community 
or click on the new Live Community icon from the ProFile toolbar (you will find this new icon 
beside the Form Explorer icon). 
 

Options packages 
 
Live Community options can be stored in an options package and therefore, if you favour, can be 
disabled for an entire office. 
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Chapter 8 - What we learned 
 
You have finished Chapter 8. Congratulations! 
 
In this chapter we learned: 
  

 Manage ProFile 

 Continue to Learn with ProFile 
 
If there are any details that you would like to review, please go through the chapter again. 
 
 
 


