Learning about Taxes with Intuit ProFile

Chapter 7: Data-mining with Client Explorer
Copyright
Copyright 2018 Intuit, Inc.
All rights reserved.
Intuit, Inc.
5100 Spectrum Way,
Mississauga, ON L4W 5S2

Trademarks
©2018 Intuit Inc. All rights reserved. Intuit, the Intuit logo, Intuit ProFile, ProAdvisor, and QuickBooks, among others, are trademarks or registered trademarks of Intuit, Inc. in Canada and other countries. Other parties’ marks are the property of their respective owners.

Notice to Readers
The publications distributed by Intuit Inc. are intended to assist educators by providing current and accurate information. However, no assurance is given that the information is comprehensive in its coverage or that it is suitable in dealing with a particular situation. Accordingly, the information provided should not be relied upon as a substitute for independent research. Intuit Inc. does not render any accounting, legal, or other professional advice nor does it have any responsibility for updating or revising any information presented herein. Intuit Inc. cannot warrant that the material contained herein will continue to be accurate or that it is completely free of errors when published. Readers should verify information before relying on them.

The material in this publication is provided for informational purposes only. Laws, regulations, policy and procedures regarding this subject are continuously changing and the information and examples are intended as general guidelines only. This publication is sold with the understanding that neither the publisher nor the author are engaged in rendering professional advice and it is recommended that such advice be obtained before acting on any information herein.

Users of this publication are responsible for their own actions and outcomes. The publishers and author therefore expressly disclaim all and any liability to any person in respect of anything and any consequence. Any examples in this book are factitious and any resemblances to actual people or circumstances are purely coincidental.
# Table of Contents

**About the Author** ................................................................................................................. 2

**Additional Resources** ........................................................................................................... 3

**Introduction** .......................................................................................................................... 4

**Benefits of Using ProFile** ..................................................................................................... 5

**Chapter 7: Data-mining with ProFile’s Powerful Client Explorer** ........................................... 6

**Chapter 7 Learning Objectives** .......................................................................................... 6

**Introducing Client Explorer** .................................................................................................. 6

**EFILE with Client Explorer** .................................................................................................. 14

**Printing and Exporting with Client Explorer** ....................................................................... 16

**Chapter 7 Quiz** .................................................................................................................... 27
Michael Di Lauro, CPA CMA, *Hein & Associates CPAs*

Michael is a CPA, CMA with a strong background in training and technology. Over the years Michael has written dozens of training materials and has taught QuickBooks, ProFile, Microsoft Office and other software applications to thousands of individuals. When not teaching or training you’ll often find Michael in various coffee shops, throughout Ottawa and Montreal, discussing business and technology with friends, clients and, even, perfect strangers.
**ADDITIONAL RESOURCES**

In addition to this document, Intuit provides numerous resources to accounting professionals. Refer to these sites to explore additional tutorials and training opportunities:

- [http://accountant.intuit.ca/professional-accounting/index.jsp](http://accountant.intuit.ca/professional-accounting/index.jsp)
- [http://profile.intuit.ca/professional-tax-software/index.jsp](http://profile.intuit.ca/professional-tax-software/index.jsp)
- [http://profile.intuit.ca/professional-tax-software/training.jsp](http://profile.intuit.ca/professional-tax-software/training.jsp)
Introduction

Intuit ProFile Tax software is reliable and easy-to-use, and it offers sophisticated features that help tax preparers experience a more productive tax season. The following paragraphs summarize the key components of Intuit ProFile Professional Tax software.

ProFile T1 imports and converts data created by competing software products. Whether you carry files forward individually or in batches, you will find the process quick and convenient. Using ProFile’s WYSIWYG (what you see is what you get) forms, you can view and edit federal T1 and Québec TP1 forms in either French or English. You can also print all tax forms in either language at the click of a button.

ProFile T2 is designed for professional preparation of corporate tax returns in all provinces and territories. ProFile T2 includes:

- Federal T2 returns, including T2 RSI (for 2006-2009 and earlier) and Corporation Internet Filing
- Provincial corporate tax returns for Alberta (including AT1 RSI), for Ontario returns with taxation years ending prior to January 1, 2009 (including CT23 disk filing) and for Quebec (CO-17).
- Provincial capital tax returns for Manitoba, Saskatchewan and British Columbia

ProFile T3 prepares Trust income tax returns and supporting schedules, including T3 and T5 slips that the trust receives. Simply enter slip information on intuitive income-reporting screens and ProFile T3 automatically transfers the amounts to the appropriate forms. ProFile T3 also integrates business and rental income statements. In addition to T3 slips, the software allows you to prepare NR4 slips for non-resident taxpayers (including the NR4 summary).

ProFile FX (Forms Expert) gives you more than 80 of the most commonly-used CRA forms which supplement the form-sets in Intuit’s other tax applications. Here are a few highlights of ProFile FX:

- Customizable options help you complete and file the forms you need.
- Automatic form selection facilitates form printing.
- Audit and review features help pinpoint potential errors
- Forms flexibility lets you print facsimile forms on plain paper or directly onto pre-printed CRA forms. ProFile FX also prepares magnetic media files for T4, T4A, T5, T5018 and NR4 slips, as well as for the RL1, RL2, RL3 and RL4.
- Import identification from an existing ProFile T1 or T2 data file minimizes potential data entry errors.
Benefits of Using ProFile

ProFile is powerful, efficient and secure tax software that helps you get your work done fast and efficiently. Here’s how you benefit by using Profile:

- With phone, email or in-product live chat support, you have year-round access to knowledgeable Canadian technical experts
- With its comprehensive set of forms and schedules, ProFile lets you handle just about every tax scenario in any jurisdiction, including Québec
- With a built-in auditor that runs up to 2,800 diagnostic checks of your tax returns, ProFile has your back
- Flexible Licensing means you can install ProFile on more than one personal computer without having to pay additional licensing fees
- Work with QuickBooks? So does ProFile! There’s no need for manual data entry because you can now export data from QuickBooks directly into ProFile

Plus, with ProFile you enjoy a consistent level of advanced features that include:

- Customizable client correspondence
- Database queries and reporting
- Online tools to quickly and easily stay in touch with your clients
CHAPTER 7 LEARNING OBJECTIVES

At this chapter’s conclusion, students will understand:

- What Client Explorer is and what information it provides
- How to use Client Explorer at a basic level
- How to use Client Explorer’s powerful reporting tools

INTRODUCING CLIENT EXPLORER

Client Explorer is a database, built into ProFile, that helps you view and manage your clients and their files. With Client Explorer, you can create custom filters that let you open, carryforward and batch EFILE tax returns, and export and print information on your client and their tax files. The first time you save a new client file, Client Explorer automatically adds a record for that client to the database. And whenever you make a change to a client file, ProFile updates the record for that client.

Client Explorer does not store all of the data found in each individual client file. Instead, it contains references to the file location. However, you can still print reports and export files that include the data from those client files. Also, you must use Client Explorer to print groups of returns or to file groups of returns by EFILE.

It’s important to note that, in addition to Client Explorer, ProFile offers a separate and functionally-different client database called Classic Database. This booklet only covers Client Explorer.

Note: You can use either the Classic Database or Client Explorer — not both.

Client Explorer Advantages

The benefits of Client Explorer include:

- Faster network access: Client Explorer works on standalone workstations or small networks, and also provides faster access for larger offices that share a database over a network.
- Client-centred records: Client Explorer groups files for the same client in a single client record, regardless of the type or year of the file. You see all of a client's files and returns in one place.
- Customized views: You can set and personalize Client Explorer views and save those settings. You can use filters to quickly and easily change how you view your files and which files you view.
- Intuitive batch functionality: Most multi-file-select actions work the same way as Microsoft Windows®. You can use filters to view only the files you need, select all of the visible files, and then select an action from the Database menu or from a right-click menu.
- Access to client details: You can use Client Explorer as an address book or contact list. You can change client addresses in the Client Explorer without affecting previously-filed returns. And you can customize the Details pane to include any fields from client returns.

Setting up

You must first setup Client Explorer, and the set-up options depend on whether the tax preparer works alone as a sole practitioner, or works with other in a shared network environment.

Setting up Client Explorer for a Sole Practitioner

- Click Options -> Database
- Select the *Client Explorer* radio button.
- Click Setup Wizard

- Click *Use Client Explorer* and in the following window, click *No* to indicate that you are a sole practitioner

- As a sole practitioner, select the first radio button and click *Next*
- Finally, click *Finish*
Setting up Client Explorer for a Shared Database

- Go back the Setup Wizard, and click Yes at the prompt about working with different people
- In a following window, click the second radio button to make the computer a shared database
- Name your shared database, click OK to accepts any Windows prompts (such as ProFile Privilege Elevation), and click Finish to complete the process
Using Client Explorer

- To open Client Explorer just press the F3 key. The first time it launches, Client Explorer displays an empty window.
- To load existing files, just click Index.

- Browse to the file location (usually My ProFile Data) and click Include subfolders.
- Indicate how you want Client Explorer to handle password protected files.
- Click OK.
After the indexing process is finished, Client Explorer displays all tax files stored in the designated folder.

By default, View is set for All Clients. To change that view, just click the dropdown.
• The Contact View, for example, displays full contact information for all your clients
• Use the tabs to narrow your search parameters

• Client Explorer lets you customize views by setting filters
• Click Filter to open the bottom panel and customize the files that Client Explorer displays
• The Filters panel lets you select a wide range of parameters including, tax types, tax years, client and file status, date-range and so on
• Once you create a view that suits your working style, in the window above, click **Save View**.
• In the dialog box that opens, name your customized view and click **OK**.

**Using Client Explorer to find files**
• **Client Explorer** has a Search tool that helps you find a specific client file
• Use the dropdown field to select the search parameter
• Type the query term, click **Search** and Client Explorer will display all files matching your search query
Client Explorer as a Contact Manager

- You can easily use Client Explorer as a Contact Manager. Just select a file (by clicking into its checkbox) and the left pane displays contact information for that client.

- To carry out more actions, right-click a file to open a context-sensitive window that lets you, among others, Open, Carryforward or Print Files, as well as Export, Copy or Delete them.
Chapter 4 introduced CRA’s EFILE system and described how a tax prepare uses EFILE to electronically file a client’s T1. This section illustrates how you can use Client Explorer to EFILE multiple T1s at the same time.

**Batch EFILE with Client Explorer**

To create EFILE files for a group of returns:

- Press F3 to open Client Explorer
- In the client list pane, click the Select all tab (on the left)
In the View drop-down list, select the type of EFILE operation that you want to perform. ProFile filters the list to display only files with the selected status.

- To view tax files eligible for EFILE, select **T1 – EFILE Eligible**.
- From the list of eligible files, select the files that you want to include in the next transmission.
- To prepare the files for submission, choose **Build EFILE**.

If necessary, in the Build window that opens, further specify the type of EFILE file to create (or the **Agency**, **Data Type** and **Slip Type** when you are building an electronic media file for slips/relevés).

- Click OK when you're done.

ProFile reports progress on the selected returns as it builds them. A **Successful** build status should appear next to each return.

- Click **Transmit Now** to EFILE the batch.
For more details on transmitting T1 and TP1 returns that you prepared in this way, go to ProFile Help and search for “Transmit a batch of EFILE Online files”

**PRINTING AND EXPORTING WITH CLIENT EXPLORER**

**Export to Excel**  
Here’s how you can export data from Client Explorer to Microsoft Excel™:

- From *Client Explorer*, select the files for the year and module you’d like to export
- Click the *Database* menu and select *Export*
• From the Export Files dialog box, click Options

The Fields tab of the Export Options window (below) is where you choose the fields code for the information that you want to include in your export

- Click Add to begin selecting the fields you’d like to export
- Select the field to add in your export, then click OK
- To include more fields, keep clicking Add

There are two files you need to create. One is the design of the export which indicates what information you need to extract from the ProFile tax files. This file is saved as a .qex file and it is configured on the Fields tab of the Export Options window above. The second file stores the actual information that will be used to import into Excel. This second file is usually saved as a .txt or .csv file. You save this file on the Format tab of the Export Options window above.
To create and save the second file, navigate to the Format tab and click the Browse button to the right of the Export to File field.

Type in a name for your file.

If you're using a .csv extension, click the dropdown and select All files.

Click Open.

ProFile will return to the Export Options window where you can finalize your setup options.

Note that the file is saved in MyProFile Data\Reports and it is here that you will browse to later to import the data into Excel.

Choose the export type, Tab Delimited, for example.

Check Export Field Names, which will put the field code at the top of each column in Excel.
• Go back to the Field tab and click Save
• ProFile will save the design of the report as a .qex file
• Click Save once more to save the .qex file
• Click OK, and you’ll be taken back to the main export window

• At the Export File window, click Export and the information will be sent to the .csv file that you created earlier
You are now ready to import the data to Excel, all you need to do is find the .csv file and open it in Excel.

Printing Reports
The steps for printing reports are similar to what you just learned for exporting data. As illustrated in the previous example from Client Explorer, select the files to print from, and then click *Database > Print Report*

- In the Create Report window, click *Options*.
On the **Header** tab, select text that will appear on all pages. For example, to use today’s date, double-click on **Today**

- The top row of the **Fields** tab displays column headings. Select the first cell and then click **Properties**
- In the **Title Cell Properties** window, you can set up text formatting and enter the text for Title 1
- Click **OK** to close the window
You now need to input data for the report. Double-click the cell directly under *First Name* and choose from a list of *Field Codes*.

In the *Select Field* window, choose *ClientFistName* and click *OK*.

Click *Add* and repeat the step above to add more fields. Once done, your report template will look like this.
• Use the Footer tab to set up footnotes that appear at the bottom of each page.

• Use the Format tab to set up other options such as the printer that will generate the report.
• Save your setup options and click OK to open the Create Report window. Click Print to run the report.

• Here is your report
Creating Mailing Labels with Client Explorer

Before using Client Explorer to print labels, you will, of course, have to set up your mailing labels.

- Go to the File menu and select Setup Mailing Labels.
- Click a Module tab.
- Click the dropdown to choose your label type.
- If you’d like to format your own label, click New Label (ProFile will designate it as User Label 1) and enter the label rows, columns on the right side of the window below.
- Click OK.
To print mailing labels, follow these steps.

*Note that when printing a group of labels, all files must be of the same module and tax year.*

- Press F3 and from Client Explorer, choose just a few files for a test run

- Click Database > Print Mailing labels
- Mailing labels for spousal returns will show both spouses’ names. To avoid printing two labels for each spousal return, check the box marked *Print only one label for coupled returns*
- Click OK

Make sure to feed the correct labels into your printer, before starting the print job.
Chapter 7 Quiz

**Question 1:** Client Explorer is a database that lets you:

A. View and manage your clients and their tax files  
B. Create custom filters for selecting only certain types of files  
C. Print or export customized reports  
D. All the above

**Question 2:** True or False: ProFile has two different database tools: Client Explorer and Classic Database, and you can use both at the same time

**Question 3:** The first time you launch Client Explorer you must:

E. Index the existing files  
F. Copy files from the data folder and paste them into Client Explorer  
G. Run the Synchronize and Archive feature  
H. Ensure that all files are linked to each other

**Question 4:** True or False: You cannot share a Client Explorer database with other tax preparers

**Question 5:** True or False: Client Explorer can only access files stored in one folder and its nested subfolders

**Question 6:** To use Client Explorer as a contact manager, you should:

I. Create a customized report and export it to Excel  
J. Extract the names and addresses from within the T1 view  
K. You cannot, in fact, use Client Explorer as a contact manager  
L. Click the dropdown arrow in the View field and select Contact View

**Question 7:** True or False: You can create your own customized view options (called Filters) in Client Explorer
**Question 8:** True or False: You can use Client Explorer to prepare mailing labels

**Question 9:** Client explorer lets you:

M. Carry forward prior-year tax files  
N. EFILE tax returns in a batch  
O. Select and print tax files  
P. All the above

**Question 10:** There are two special types of files Client Explorer prepares for print jobs and for exporting. The file extensions of these two files are:

A. .qex and .qrp  
B. .pdf and .atf  
C. .qex and .csv  
D. .gt1 and .at2